Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-13-2018 06:50 AM - edited 09-16-2022 06:20 AM
Datanode unable to communicate with NameNode and getting following error message. I am using cloudera 5.14.0 version and i do not have DNS
NN Static IP : 192.168.0.12 but it is trying other ip address 192.168.0.121
Did anyone face this issue earlier.. I am unable to proceed further.
Thanks in advance.
Error message.
18-06-13 19:02:29,352 INFO org.apache.hadoop.hdfs.server.datanode.DataNode: Block pool BP-405258512-192.168.0.12-1528825240439 (Datanode Uuid 2bba9d98-a00c-40f0-9a0c-a479d071ba9f) service to cn3.hadoop.com/192.168.0.14:8022 beginning handshake with NN
2018-06-13 19:02:29,716 ERROR org.apache.hadoop.hdfs.server.datanode.DataNode: Initialization failed for Block pool BP-405258512-192.168.0.12-1528825240439 (Datanode Uuid 2bba9d98-a00c-40f0-9a0c-a479d071ba9f) service to cn3.hadoop.com/192.168.0.14:8022 Datanode denied communication with namenode because hostname cannot be resolved (ip=192.168.0.121, hostname=192.168.0.121): DatanodeRegistration(192.168.0.12, datanodeUuid=2bba9d98-a00c-40f0-9a0c-a479d071ba9f, infoPort=50075, infoSecurePort=0, ipcPort=50020, storageInfo=lv=-56;cid=cluster8;nsid=762896661;c=0)
Created 06-13-2018 07:56 AM
I found following fix for Hadoop but I am not sure how to fix cloudera
hdfs-site.xml - Need to add following line.
<property> <name>dfs.namenode.datanode.registration.ip-hostname-check</name> <value>false</value> </property>
Created 06-20-2018 05:36 AM
It is a bug in 5.14.0 .. at last I fixed it.
Created 06-13-2018 07:56 AM
I found following fix for Hadoop but I am not sure how to fix cloudera
hdfs-site.xml - Need to add following line.
<property> <name>dfs.namenode.datanode.registration.ip-hostname-check</name> <value>false</value> </property>
Created 06-20-2018 05:36 AM
It is a bug in 5.14.0 .. at last I fixed it.
Created 01-08-2019 11:34 AM
How was it fixed?