Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 02-18-2016 02:03 PM - edited 09-16-2022 03:04 AM
Aftre upgrading kafka parcel from "0.8.2.0-1.kafka1.4.0.p0.56" to "2.0.0-1.kafka2.0.0.p0.12".
Running into an issue were by publishing message on to topic fails.
A simple test using kafka-console-producer fails withe error message
Error when sending message to topic TESTTOPIC with key: null, value: 9 bytes with error: Failed to update metadata after 60000 ms. (org.apache.kafka.clients.producer.internals.ErrorLoggingCallback)
Please advise.
Created on 02-18-2016 06:33 PM - edited 02-18-2016 06:35 PM
Figured out that I had to change a setting in server.properties
listeners=PLAINTEXT://hostname:9092
to
listeners=PLAINTEXT://0.0.0.0:9092
and everything seemed to work fine now.
Created on 02-18-2016 06:33 PM - edited 02-18-2016 06:35 PM
Figured out that I had to change a setting in server.properties
listeners=PLAINTEXT://hostname:9092
to
listeners=PLAINTEXT://0.0.0.0:9092
and everything seemed to work fine now.
Created 05-11-2016 02:41 PM
Hi Bhairav,
I've recently started using Cloudera Enterprise. I was wondering how you were able to solve the kafka issue. I'm still having trouble solving this issue because I don't know where the server.properties file is located.
Or where I can find the "listeners" property in cloudera manager. I tried checking kafka's configuration tab but didn't find this setting.
Created 07-29-2016 12:05 PM
in cloudera manager it is kafka.properties .
you can update values in borker configuration ==> advanced ==> Kafka broker Advanced Configuration Snippet (Safety Valve) for kafka.properties
and restart
Created 01-23-2018 11:55 AM
If you have kafka version - 0.10.2, then adding only the 'listeners' is not enough and 'advertised.listeners' should also be added to the safety valve values for 'kafka.properties'. This is more of a requirement when we set the ip address as '0.0.0.0'. The advertised.listeners value would have the exact ip/hostname:port value.
This information is clearly mentioned at - http://kafka.apache.org/documentation.html#security_configbroker