Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Exercise 1: Name node in safe mode Error

avatar
Frequent Visitor

Hi experts,

 

Im having a problem with exercise 1. When i run this sentence:

 

sqoop import-all-tables \
-m 1 \
--connect jdbc:mysql://quickstart.cloudera:3306/retail_db \
--username=retail_dba \
--password=cloudera \
--compression-codec=snappy \
--as-parquetfile \
--warehouse-dir=/user/hive/warehouse \
--hive-import

 

i'm having this error: 

ERROR tool.ImportAllTablesTool: Encountered IOException running import job: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.hdfs.server.namenode.SafeModeException): Cannot create directory /user/root/.staging. Name node is in safe mode.

 

Any suggestions?? How do i change the Name Node mode?

 

Thanks to all

 

1 ACCEPTED SOLUTION

avatar
Frequent Visitor

Apparently is solved with this

sudo -u hdfs hdfs dfsadmin -safemode leave

View solution in original post

1 REPLY 1

avatar
Frequent Visitor

Apparently is solved with this

sudo -u hdfs hdfs dfsadmin -safemode leave