Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-13-2017 12:36 PM
Hi, I am trying to install Ranger KMS in HDP 2.5 sandbox using following link.
Getting following error message in ambari-agent.log file.
AgentException: 'Script /var/lib/ambari-agent/cache/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py does not exist'
WARNING 2017-02-13 11:48:03,902 FileCache.py:168 - Error occurred during cache update. Error tolerate setting is set to true, so ignoring this error and continuing with current cache. Error details: ('Can not invalidate cache directory {0}: {1}', '/var/lib/ambari-agent/cache/common-services/RANGER_KMS/0.5.0.2.3/package', "[Errno 22] Invalid argument: '/var/lib/ambari-agent/cache/common-services/RANGER_KMS/0.5.0.2.3/package/scripts'")
ERROR 2017-02-13 11:48:03,903 CustomServiceOrchestrator.py:232 - Caught an exception while executing custom service command: <class 'ambari_agent.AgentException.AgentException'>: 'Script /var/lib/ambari-agent/cache/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py does not exist'; 'Script /var/lib/ambari-agent/cache/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py does not exist'
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/ambari_agent/CustomServiceOrchestrator.py", line 157, in runCommand
script_path = self.resolve_script_path(base_dir, script)
File "/usr/lib/python2.6/site-packages/ambari_agent/CustomServiceOrchestrator.py", line 305, in resolve_script_path
raise AgentException(message)
AgentException: 'Script /var/lib/ambari-agent/cache/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py does not exist'
WARNING 2017-02-13 11:48:03,903 ActionQueue.py:554 - 'str' object has no attribute 'has_key'
Can anyone please help me.
Created 02-13-2017 06:37 PM
what is the Ambari version are you using? If you have Ambari 2.4.x then can you check
1. "/var/lib/ambari-server/resources/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py" folder/file exist? if that does not exist then your Ambari-server is not installed properly.
2. if that file/folder is present then check for "/var/lib/ambari-agent/cache/common/services/RANGER_KMS/0.5.0.2.3/package/" at the Agent host. basically Ambari-server pushes this files/folders to Ambari-agents. so restart Agent once and then try to check.
Let me know your findings.
Let
Created 02-13-2017 06:37 PM
what is the Ambari version are you using? If you have Ambari 2.4.x then can you check
1. "/var/lib/ambari-server/resources/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py" folder/file exist? if that does not exist then your Ambari-server is not installed properly.
2. if that file/folder is present then check for "/var/lib/ambari-agent/cache/common/services/RANGER_KMS/0.5.0.2.3/package/" at the Agent host. basically Ambari-server pushes this files/folders to Ambari-agents. so restart Agent once and then try to check.
Let me know your findings.
Let
Created 02-23-2017 09:24 AM
I am also facing the same error. I am trying to add Ranger-KMS service from Ambari and while deploying i am seeing the error as "/var/lib/ambari-server/resources/common-services/RANGER_KMS/0.5.0.2.3/package/scripts/kms_server.py" does not exist.
I checked the above mentioned path and script at above path does not exist. I have downloaded HDP 2.5 Sandbox for Virtualbox and both ambari-server and ambari-agent is running on localhost and both are working fine. I think this script should come as part of HDP 2.5. It seems to be a issue in Sandbox image.
Ambari Version 2.4.0.
Could you please suggest the solution?
Thanks
Created 02-26-2017 06:19 PM
This script/path comes with Ambari-server . if does not exist you can copy that path/files from other setup. these are static files and can be copied to/from every place.