Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-21-2017 11:08 AM
Zookeeper-error
Hi There,
I'm building a 3 node cdh v5.9 hadoop cluster on centOs7 guests. At the moment, I'm using cloudera manager to install all components. But I'm running into issue every single time. I've attached failure errors for hdfs & zookeper.
Note, there is passwordless scp between servers, DNS is properly configured and also hosts are properly reachable. I've been trying this past 56 days with no success. The same config is working fine for apache hadoop.
Hope I'll get some response before the expiry of cdh trail.
Thanks,
Mrinal
Created 02-21-2017 02:56 PM
Created 02-24-2017 02:51 PM
I think I have seen this before.
Check your /opt directory on the zookeeper hosts to make sure that it has "execute" for other.
I reproduced what you see by setting the following:
drwxr-xr--. 3 root root 21 Feb 7 13:50 opt
Try running:
chmod 755
So that it looks like this:
drwxr-xr-x. 3 root root 21 Feb 7 13:50 opt
Try starting services again after that.
Regards,
Ben
Created 02-21-2017 02:56 PM
Created 02-22-2017 09:08 PM
Created 02-24-2017 12:57 PM
Created 02-24-2017 02:51 PM
I think I have seen this before.
Check your /opt directory on the zookeeper hosts to make sure that it has "execute" for other.
I reproduced what you see by setting the following:
drwxr-xr--. 3 root root 21 Feb 7 13:50 opt
Try running:
chmod 755
So that it looks like this:
drwxr-xr-x. 3 root root 21 Feb 7 13:50 opt
Try starting services again after that.
Regards,
Ben