Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-12-2016 07:37 AM
I am facing below issue while using Hive view from Ambari console:
E090 HDFS020 Could not write file /user/admin/hive/jobs/hive-job-3-2016-02-12_12-55/query.hql [HdfsApiException]
Searching through the guides I found out that HDFS user directory set up needs to be done. Following that guide am issuing command hadoop fs -mkdir /user/admin from HDFS user but it throws the below error.-bash-4.1$ hadoop fs -mkdir /user/admin mkdir: `/user/admin': Input/output error
Need your help on this issue.
Note : Using HDP 2.3.4.0 and it was configured using Amabri and also in that host HDFS client is running.
Created 02-12-2016 08:35 AM
Validate HDFS configuration and make sure HDFS service is running.
Input/Output error can be thrown because of multiple reasons (wrong config, NN not available,....)
Could you please check the HDFS Namenode Log and see if any error/exception is shown.
Created 06-20-2017 01:04 PM
Thanks. hadoop.proxyuser.root.hosts=* also worked for me, too.
Created 04-08-2017 09:25 AM
yes for some reason after enabling ranger , it will remoce the hadoop.proxyusers.root.hosts settings even if you had it before.... annoying
Created 08-29-2017 01:05 PM
Yes it worked for me too by changing this setting in HDFS