Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Kafka does not start after Kerborising the clustrer

avatar
Rising Star

All my HDP components succeded to start after kerborising my cluster, except Kakfa...

This is what I can see in /var/log/kafka/server.log:

[2016-01-06 23:04:54,931] FATAL Fatal error during KafkaServer startup. Prepare to shutdown (kafka.server.KafkaServer) java.lang.IllegalArgumentException: You must pass java.security.auth.login.config in secure mode. at org.apache.kafka.common.security.kerberos.Login.login(Login.java:297)

Ambari logs do not show any error message related to the Kafka fail while restarting the service.

I am running HDP 2.3 and Ambari 2.1

Any clue ?

1 ACCEPTED SOLUTION

avatar

export KAFKA_KERBEROS_PARAMS in /usr/hdp/current/kafka-broker/config/kafka-env.sh you can do this using ambari as well look for kafka-env config template under kafka service.

KAFKA_KERBEROS_PARAMS="-Djava.security.auth.login.config=/usr/hdp/current/kafka-broker/config/kafka_jaas.conf"

View solution in original post

6 REPLIES 6

avatar

export KAFKA_KERBEROS_PARAMS in /usr/hdp/current/kafka-broker/config/kafka-env.sh you can do this using ambari as well look for kafka-env config template under kafka service.

KAFKA_KERBEROS_PARAMS="-Djava.security.auth.login.config=/usr/hdp/current/kafka-broker/config/kafka_jaas.conf"

avatar
Rising Star

Thank you ! That was fast 🙂

avatar
Master Mentor

@Ali Gouta Schintalapani is Kafka committer 😉 http://kafka.apache.org/committers.html

avatar
New Member

Kafka is getting started, but through java application I am not able to send message to kafka topic, I have already passed principalName and keytab through application. and set one property CommonClientConfigs.SECURITY_PROTOCOL_CONFIG, "PLAINTEXTSASL",

it gives same error - You must pass java.security.auth.login.config in secure mode

avatar
Super Collaborator

Thanks for this post. kudos!

avatar

Thanks...helped me out right away!