Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-01-2016 03:39 AM
Hi
We are getting this error while running Kafak producer.Any inputs
sh kafka-console-producer.sh --broker-list xxxxxxxxx.com:6667 --topic test1 Throwing following error [2016-06-30 12:40:25,122] WARN Error while fetching metadata [{TopicMetadata for topic test1 -> No partition metadata for topic test1 due to kafka.common.TopicAuthorizationException}] for topic [test1]: class
Created 07-01-2016 09:07 AM
Hi
Solved this issue .there was left over from a failed kerbors implementation.So Kafka was trying to get authorised from Kerbors hence the AuthorizationException removed it and restarted Kafka .Every thing works fine.
Created 07-01-2016 05:38 AM
Can you try deleting the topic test1.
Replace localhost with zookeeper host in below command.
bin/kafka-topics.sh --zookeeper localhost:2181 --delete --topic test1
Created 07-01-2016 09:07 AM
Hi
Solved this issue .there was left over from a failed kerbors implementation.So Kafka was trying to get authorised from Kerbors hence the AuthorizationException removed it and restarted Kafka .Every thing works fine.
Created 11-20-2016 11:46 PM
how did you solve this issue ? what clean-up is required so kafka does not need authorization ?
i'm getting the same issue .. I'm on HDP 2.4.
thanks for your help in advance.