Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-15-2016 06:07 AM
I have namenode HA configured with Kerberos authentication, when ranger hdfs plugin is disabled, my hdfs services are running fine, when I enable ranger HDFS plugin then my namenode is unable to come up because of below error:
File "/usr/lib/python2.6/site-packages/ambari_simplejson/decoder.py", line 353, in raw_decode raise
ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded I know there is know issue - if we change ranger admin UI password, then we also need to modify the same password in admin_password field under advance_ranger_configs section via Ambari UI. I tried doing the same thing but its not working.
Anyone has any idea or has seen this issue in past ?
Created 02-08-2016 04:56 PM
Created 01-15-2016 06:30 AM
Can you look into ambari and hdfs logs and check whether their is any message that has more details, especially what file/object Ambari is trying to decode?
Do you see a repository for HDFS in Ranger?
I have a cluster with NN HA and Ranger HDFS plugin enabled running on HDP 2.3.2 and Ambari 2.1.2.1 without any issues.
Edit: What version of HDP and Ambari do you have?
Created 01-20-2016 03:10 AM
Sure I will check. I have HDP 2.3.2 and Ambari 2.1.1
Created 01-15-2016 06:52 AM
Can you make sure that the password for amb_ranger_admin in RangerAdmin->User is the same as in Ambari -> Ranger -> Config -> Ambari Admin User
Created 01-20-2016 03:09 AM
I tried changing password for amb_ranger_admin however no luck. will update you once I get it working
Created 02-02-2016 06:07 PM
@Kuldeep Kulkarni has this been resolved? Please accept best answer or provide your own solution.
Created 02-04-2016 09:16 AM
Hello
I came across your problem and it seems to be a major issue. I've posted a question regarding this issue. We use Ranger for managing hive authorizations - and after changing the Ranger Admin password we can no longer use it for that. To be more precise - HiveServer2 won't start unless we disable Ranger as the authorization manager for hive in Ambari. More details in my post: https://community.hortonworks.com/questions/14329/hiveserver2-wont-start-after-changing-rangers-admi...
I really hope someone will fix this bug.
Adi
Created 02-08-2016 04:56 PM
Please see my suggestion at https://community.hortonworks.com/questions/14329/hiveserver2-wont-start-after-changing-rangers-admi...
Created 04-04-2016 07:50 PM
Hello
I'm having the same problem.
After changing ranger admin password in ranger & in ambari (under ambari ranger config) hive server won't start.
I get No json object could be decoded.
Only if I disable ranger from hive authorization it starts.
Hdp 2.3.2
Ambari 2.1.2.1
Any help would appreciated.
Adi