Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-08-2018 01:55 AM
Hello,
I have setup Hive configured with Ranger.When I'm trying to configure the ODBC, I'm getting the below error.
Jul 08 00:48:36.432 INFO 5764 TETSaslClientTransport::SaslLoggingCallback: Realm callback found. The realm returned was: TEL1.AZURE.JPNAP.CORPINTRA.NET
Jul 08 00:48:36.432 INFO 5764 TETSaslClientTransport::SaslLoggingCallback: Kerberos principal: hiveranger/[email protected]
Jul 08 00:48:36.451 DEBUG 5764 TETSaslClientTransport::SaslLoggingCallback: GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Server not found in Kerberos database)
Jul 08 00:48:36.451 TRACE 5764 HardyTCLIServiceClient::~HardyTCLIServiceClient: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyConnection::~HardyConnection: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyConnection::Disconnect: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyConnection::CleanUpConnEstablishThread: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyHiveClientFactory::~HardyHiveClientFactory: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardySessionManager::~HardySessionManager: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyHiveCxnPool::~HardyHiveCxnPool: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyHiveCxnFactory::~HardyHiveCxnFactory: +++++ enter +++++
Jul 08 00:48:36.452 TRACE 5764 HardyHardyQuotedIDManager::~HardyHardyQuotedIDManager: +++++ enter +++++
Kindly let me know, if someone encountered this issue
Regards
Created 07-09-2018 04:59 AM
Hi @Srinivasan Govindasamy!
Are you able to connect to your kerberos database (host receiving this error)? If so, check if your /etc/krb5.conf > Realm or ambari kerberos configs match with the realm requested, as I can see they look a little bit different.
TEL1.AZURE.JPNAP.CORPINTRA.NET != hiveranger/qazumjebdpXXX.corpintra.net@CORPINTRA.NET
Also, check the ranger logs if you can find any issue as well 🙂
Hope this helps!
Created 07-09-2018 04:59 AM
Hi @Srinivasan Govindasamy!
Are you able to connect to your kerberos database (host receiving this error)? If so, check if your /etc/krb5.conf > Realm or ambari kerberos configs match with the realm requested, as I can see they look a little bit different.
TEL1.AZURE.JPNAP.CORPINTRA.NET != hiveranger/qazumjebdpXXX.corpintra.net@CORPINTRA.NET
Also, check the ranger logs if you can find any issue as well 🙂
Hope this helps!
Created 07-09-2018 05:36 AM
Hello @Vinicius Higa Murakami,
thanks for the reply. The issue is resolved now. I have wrongly used the AD FQDN under Host FQDN field.
also one more note, it was not working when i use different service name other than "hive"snapshot.gif