Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-27-2016 08:57 AM
I am seeing the following when it is trying to install Ranger Admin on the Ranger host server:
2016-01-27 08:48:59,962 [I] Database ranger already exists. 2016-01-27 08:48:59,962 [I] ---------- Granting permission to Ranger Admin db user ---------- 2016-01-27 08:48:59,962 [I] ---------- Granting privileges TO user 'rangeradmin'@'%' on db 'ranger'---------- SQLException : SQL state: 42000 com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 'root'@'hostname' to database 'ranger' ErrorCode: 1044 SQLException : SQL state: 42000 com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 'root'@'hostname' to database 'ranger' ErrorCode: 1044 2016-01-27 08:49:00,520 [E] Granting privileges to 'rangeradmin' failed on 'ranger'
I have logged onto MySQL on the host machine and granted the following privileges and still the installation throws Access Denied error.
Created 01-27-2016 11:21 AM
Try this
grant all privileges on *.* to 'root'@'host' identified by 'password' with grant option;
then restart/reinstall rangeradmin process
Created 01-27-2016 09:50 AM
What privileges did you grant? I think there is something missing in your post
Created 01-28-2016 01:51 AM
Something like this:
GRANT ALL ON mydb.*TO'myuser'@'%';
Created 01-27-2016 10:15 AM
Try this:
GRANT ALL PRIVILEGES ON *.* TO 'root'@'hostname' WITH GRANT OPTION;
Created 01-27-2016 11:01 AM
@Kay Aries you have MySQL issue not a ranger issue. Please see this Thread
Created 01-27-2016 11:21 AM
Try this
grant all privileges on *.* to 'root'@'host' identified by 'password' with grant option;
then restart/reinstall rangeradmin process
Created 01-27-2016 03:08 PM
Ranger is in this state now:
Invalid event: HOST_SVCCOMP_OP_IN_PROGRESS at INSTALL_FAILED
I will delete the service through Rest API and will try it again.
Thanks for all the help.
Created 01-27-2016 04:53 PM
I did a re-install and Neeraj's solution worked for me. Thank you all, guys.
Created 02-19-2016 02:10 PM
Thanks Neeraj...your solution worked
Created 07-07-2017 11:46 PM
It worked for me when used with "identified by 'password' " string in grant all privileges on *.* to 'root'@'oozie-test2' identified by 'password' with grant option;