Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Security features not available in HBase (Kerberized cluster)

avatar
Rising Star

Error "DISABLED: Security features are not available" is thrown

hbase(main):002:0> user_permission 'TABLE_NAME'
User              
                                                                        
   
Namespace,Table,Family,Qualifier:Permission                             
                                                                        
                                                                        
                                                       

ERROR: DISABLED: Security features are not available

Here is some help for this command:
Show all permissions for the particular user.
Syntax : user_permission <table>

Note: A namespace must always precede with '@' character.

For example:

    hbase> user_permission
    hbase> user_permission '@ns1'
    hbase> user_permission '@.*'
    hbase> user_permission '@^[a-c].*'
    hbase> user_permission 'table1'
    hbase> user_permission 'namespace1:table1'
    hbase> user_permission '.*'
    hbase> user_permission '^[A-C].*'

Below configuraton is set in hbase-site.xml

<property>
      <name>hbase.coprocessor.region.classes</name>
 
     
<value>org.apache.hadoop.hbase.security.access.AccessController,org.apache.hadoop.hbase.security.token.TokenProvider,org.apache.hadoop.hbase.security.access.SecureBulkLoadEndpoint</value>
    </property>

    <property>
      <name>hbase.coprocessor.regionserver.classes</name>
      <value>org.apache.hadoop.hbase.security.access.AccessController</value>
    </property>
       <property>
      <name>hbase.coprocessor.master.classes</name>
      <value>org.apache.hadoop.hbase.security.access.AccessController</value>
    </property>

      <property>
      <name>hbase.security.authorization</name>
      <value>true</value>
    </property>

        <property>
      <name>hbase.security.authentication</name>
      <value>kerberos</value>
    </property>

        <property>
      <name>hbase.master.kerberos.principal</name>
      <value>hbase/[email protected]</value>
    </property>

    <property>
      <name>hbase.master.keytab.file</name>
      <value>/etc/security/keytabs/hbase.service.keytab</value>
    </property>

1 ACCEPTED SOLUTION

avatar

Got the logs from @nshetty and checked somehow the hbase:acl table is not created because earlier hbase:acl znode is present but the table is not present. Once after deleting the hbase:acl table znode and restarting the service it's working fine.

View solution in original post

2 REPLIES 2

avatar

It seems your hbase:acl table is not created.

can you check hbase-site.xml at master side as well it should have:-

       <property>      
<name>hbase.coprocessor.master.classes</name>    
  <value>org.apache.hadoop.hbase.security.access.AccessController</value>  
  </property>

try restarting your cluster as postStartMaster step should create this table, once you are able to do scan 'hbase:acl' , you will not see above error "ERROR: DISABLED:Security features are not available"

avatar

Got the logs from @nshetty and checked somehow the hbase:acl table is not created because earlier hbase:acl znode is present but the table is not present. Once after deleting the hbase:acl table znode and restarting the service it's working fine.