Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 11-12-2017 11:07 PM - edited 08-18-2019 01:13 AM
I have created a PIG view in Ambari Server and cannot access it due to error "Service 'webhcat' check failed: RA080 Can't determine WebHCat hostname neither by associated cluster nor by webhcat.hostname property"
I used also the below configuration:
| hadoop.proxyuser.hcat.groups=*
hadoop.proxyuser.hcat.hosts=* webhcat.proxyuser.root.groups=* webhcat.proxyuser.root.hosts=* |
But, I have still problem. How can I resolve it?
Created 11-13-2017 12:30 AM
Created 11-13-2017 12:14 AM
Can you share your Pig View configurations and HDP version ?
Created on 11-13-2017 12:31 AM - edited 08-18-2019 01:13 AM
Dear Dinesh,
HDP version is 2.6. Pig View Configuration is in the below figures:
Created 11-13-2017 12:30 AM
Created 11-13-2017 12:47 AM
Thanks for link. One step is about Hive configuration, but I do not want it. Or is it mandatory for Pig View? this link: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-views/content/setup_WebHCat_proxy...
Created 11-13-2017 06:14 AM
You need to do that step. That is the one which configures the proxy for your ambari principal.