Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
here's the message
here's a quick fix, replace root with the user executing the job
Created 11-25-2015 01:23 AM
This should help:
PROBLEM Customer unable to see logs via Resource Manager UI due to incorrect permissions for the default user dr.who.
RESOLUTION Customer changed the following property in core-site.xml to resolve the issue. Other values such as hdfs or mapred also resolve the issue. If the cluster is managed by Ambari, this should be added in Ambari > HDFS > Configurations >Advanced core-site > Add Property
hadoop.http.staticuser.user=yarn
Created 10-29-2015 04:02 PM
Which Ambari version did you use to install the cluster?
Ambari fixed the issue in its 2.1.1 version, see AMBARI-12415. The issue was with the setting of property "yarn.admin.acl" value.
Created 10-29-2015 04:11 PM
this is in Sandbox 2.3.2
Created 10-29-2015 09:55 PM
Hi Artem,
You have steps to repro? I run a tez job and don't get the behavior.
Regards,
Robert
Created 10-30-2015 04:25 AM
@[email protected] same here sandbox 2.3.2. it's easy to reproduce, it happens to all applications created by spark-shell, spark-submit or zeppelin
Created 10-30-2015 12:44 PM
not just spark, mapreduce as well. I ran an oozie job that executes a pig script in mapreduce mode and it prompted that message
Created 10-30-2015 03:43 PM
@[email protected] I was just able to confirm this behavior on the latest 2.3.2 sandbox when you go to Resource Manager UI , you get the same error message [Dr.Who]
Created 11-25-2015 01:23 AM
This should help:
PROBLEM Customer unable to see logs via Resource Manager UI due to incorrect permissions for the default user dr.who.
RESOLUTION Customer changed the following property in core-site.xml to resolve the issue. Other values such as hdfs or mapred also resolve the issue. If the cluster is managed by Ambari, this should be added in Ambari > HDFS > Configurations >Advanced core-site > Add Property
hadoop.http.staticuser.user=yarn
Created 11-25-2015 02:11 AM
Just tested this, it does work, can we set this by default in the future Sandbox releases?
Created 07-05-2016 06:15 AM
Applied the suggested parameter on our env cluster, and it works!
Thanks!
https://community.hortonworks.com/questions/43331/user-drwho-is-not-authorized-to-view-the-logs.html