Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-05-2017 12:27 PM - edited 09-16-2022 03:53 AM
Hi experts
I have 3 nodes hadoop kerberized cluster. But while i am opening view i am getting below error:
SIMPLE authentication is not enabled. Available:[TOKEN]
Below is the solution i came across as per the link.
As per the above solution i have made 2 changes:
"hadoop.security.authentication" to "simple" in the file /etc/hadoop/conf/core-site.xml in ambari.
'hive.server2.authentication' is set to 'None'
But while i am able to open the views but node managers and datanodes gives error to kerberos..as below:
2017-01-05 16:12:22,661 WARN authorize.ServiceAuthorizationManager (ServiceAuthorizationManager.java:authorize(119)) - Authorization failed for yarn (auth:SIMPLE) for protocol=interface org.apache.hadoop.yarn.server.api.ResourceTrackerPB, expected client Kerberos principal is nm/[email protected] 2017-01-05 16:12:22,661 INFO ipc.Server (Server.java:authorizeConnection(2039)) - Connection from 192.168.56.41:34702 for protocol org.apache.hadoop.yarn.server.api.ResourceTrackerPB is unauthorized for user yarn (auth:SIMPLE) 2017-01-05 16:12:22,661 INFO ipc.Server (Server.java:doRead(850)) - Socket Reader #1 for port 8025: readAndProcess from client 192.168.56.41 threw exception [org.apache.hadoop.security.authorize.AuthorizationException: User yarn (auth:SIMPLE) is not authorized for protocol interface org.apache.hadoop.yarn.server.api.ResourceTrackerPB, expected client Kerberos principal is nm/[email protected]]
Please help me to have kerberize cluster and views.
Created 01-06-2017 06:50 AM
As the error you attached as part of "files.txt" shows:
500 SIMPLE authentication is not enabled. Available:[TOKEN, KERBEROS]
Please refer to last point : https://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_ambari_views_guide/content/_Troubleshoot...
.
If your cluster is configured for Kerberos, you cannot use the Local Cluster Configuration option. You must use the Custom Cluster Configuration option and enter the WebHDFS FileSystem URI.
For example: webhdfs://namenode:50070
As per your screenshot you are using "Local Cluster". Following link talks about configuring "Custom Cluster Configuration"
.
Created 01-07-2017 05:17 AM
Created 01-07-2017 05:42 AM
Please check your "hive-site.xml" property "hive.metastore.sasl.enabled" is set to "true" after enabling Kerberos?
Your ambari version seems to be too old 2.2.0 so it seems to be impacted with:
https://issues.apache.org/jira/browse/AMBARI-12257
.
Created 01-09-2017 04:43 AM
yes sasl is enabled as true in hive-site.xml. But it is still showing error.
Created 01-08-2017 04:47 AM
yes sasl is enabled as true in hive-site.xml.