Community Articles
Find and share helpful community-sourced technical articles
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.
Labels (1)

H100 Unable to submit statement show databases like '*': org.apache.thrift.transport.TTransportException: java.net.SocketException: Broken pipe"

The Ambari view throws the following error: H100 Unable to submit statement show databases like '*': org.apache.thrift.transport.TTransportException:java.net.SocketTimeoutException: Read timed out And I can no longer view database or run queries in the Ambari view. The problem appears to resolve itself after some time, but then will reappear after running a sequence of queries in the Hive view.

1) This should be fixed in Ambari 2.2

2) Browser Refresh fixed it: When connection was open for too long then there was a broken pipe when you tried to access the hive view. When you did a restart to opened a fresh connection and was able to connect.

2,908 Views
0 Kudos
Comments

I tried many things, the only thing fixed the issue is rebooting the sandbox VM.

Hi - I am having the same problem and have restarted my VM to no success. My tables have still not reappeared even though it has been some time. Can anyone help?

Thanks

Any fix for the issue yet ? I still have this issue . Is restarting ambari the only option ?

Ambari server and Hive restart worked for me

Please restart the Ambari and it will solve your issue. It worked for me.

-Ashutosh

Hi,

I also had the same issue, ambari-server restart could resolve my issue.

Regards,

Harshit Shah

Don't have an account?
Coming from Hortonworks? Activate your account here
Version history
Revision #:
1 of 1
Last update:
‎02-09-2016 10:11 PM
Updated by:
 
Contributors
Top Kudoed Authors