Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Created on 02-20-202002:09 AM - edited 09-16-202201:45 AM
LLAP Service sometimes may fail to startup after HDP upgrade with the following error:
Error::
Caused by: org.apache.hadoop.security.KerberosAuthException: failure to login: for principal: hive/[email protected] from keytab /grid/0/yarn/local/usercache/hive/appcache/application_**********/container_***********_01_000001/keytabs/llap0.keytab javax.security.auth.login.LoginException: Pre-authentication information was invalid (24)
To resolve this issue, run the following command and start LLAP:
yarn app -destroy llap0
If the issue persists, then do the following
Check the hive.service.keytab file is available in all the hosts, run kinit and test the connectivity.
If the file is missing, recreate the keytabs on the missing hosts either through Ambari or manually (see this article for manual keytab creation).
Verify the file in HDFS and copy it to the local. Perform kinit with the copied keytab.