Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
avatar
Expert Contributor

LLAP Service sometimes may fail to startup after HDP upgrade with the following error: 

 

Error::

Caused by: org.apache.hadoop.security.KerberosAuthException: failure to login: for principal: hive/[email protected] from keytab /grid/0/yarn/local/usercache/hive/appcache/application_**********/container_***********_01_000001/keytabs/llap0.keytab javax.security.auth.login.LoginException: Pre-authentication information was invalid (24)

 

To resolve this issue, run the following command and start LLAP: 

yarn app -destroy llap0

If the issue persists, then do the following

 

  1. Check the hive.service.keytab file is available in all the hosts, run kinit and test the connectivity.
  2. If the file is missing, recreate the keytabs on the missing hosts either through Ambari or manually (see this article for manual keytab creation).
  3. Verify the file in HDFS and copy it to the local. Perform kinit with the copied keytab.
    hdfs:///user/hive/.yarn/keytabs/hive/hive.service.keytab
    hdfs dfs -copyToLocal /user/hive/.yarn/keytabs/hive/hive.service.keytab /tmp/hive.keytab

    kinit -kt /tmp/hive.keytab hive/[email protected]
    kinit: Preauthentication failed while getting initial credentials
  4.  If you get the error, to move the keytab file from hdfs location.
    hdfs dfs -cp /user/hive/.yarn/keytabs/hive/hive.service.keytab /tmp/
    hdfs dfs -rm /user/hive/.yarn/keytabs/hive/hive.service.keytab
  5. Start LLAP component.

 

 

3,787 Views
0 Kudos
Version history
Last update:
‎09-16-2022 01:45 AM
Updated by: