Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Expert Contributor

Symtoms :

NameNode HA states: active_namenodes =[], standby_namenodes =[], unknown_namenodes =[(u'nn1',

Solution :

Could be in order :

1) Ambari is doing the timeout ( 5 sec is default ) and killing the process if the NN takes long to start you can change the value of the timeout in

/var/lib/ambari-server/resources/common-services/HDFS/vXXXX/package/scripts/hdfs_namenode.py

From this:

@retry(times=5, sleep_time=5, backoff_factor=2, err_class=Fail)

To this:

@retry(times=25, sleep_time=25, backoff_factor=2, err_class=Fail)

if not enough to this:

@retry(times=50, sleep_time=25, backoff_factor=2, err_class=Fail)

2) Could be the Zookeeper not getting the status of the NN

for this you can try

  1. Restart zookeeper, if it's still not working , then try the following
  2. Check the content of the Znode ( hadoop-ha ), save the namespace of the NN and delete the content and restart the NN
5,144 Views
0 Kudos
Version history
Last update:
‎08-07-2017 10:14 AM
Updated by:
Contributors