Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
Rising Star

Affected versions:

SmartSense 1.2.x, 1.3.x with Ambari lower than 2.4.1

Symptoms:

Users / Groups are pre-created before setting up the cluster.

As such, ignore_groupsusers_create needs to be set to true so groups are not modified when services are added.

This works fine for all components except smartsense which fails with error performing usermod :

resource_management.core.exceptions.Fail:
Execution of 'usermod -G -adp-hdfs -g adp-hadoop adp-xxxx' returned 6.  usermod: group 'adp-hdfs' does not exist

This group does NOT exist.

Note, within the stdout you do actually see the following message:

Skipping creation of User and
Group as host is sys prepped or ignore_groupusers_create flag is on

Reason:

The “ignore_groupsusers_create” configurations was not considered while adding / installing SmartSense service.

Solution:

New fix is available in Ambari 2.4.2.6-5 or higher. Upgrade is the cleanest solution in this case.

1,195 Views
0 Kudos
Version history
Last update:
‎02-19-2020 07:53 AM
Updated by:
Contributors