Community Articles
Find and share helpful community-sourced technical articles
Labels (2)
Expert Contributor

The latest Docker version available form official Centos and RedHat repository has an issue preventing to exec the container.

Issue when starting Cloudbreak is the following:

Starting Cloudbreak
generating docker-compose.yml
generating uaa.yml
Initialize and migrate databases
Creating cbreak_commondb_1 ...
Creating cbreak_commondb_1 ... done
[ERROR] The database hasn't started within 30 seconds.

Docker version: docker-1.13.1-84.git07f3374.el7.centos.x86_64

There are the following solutions, you can choose either:

  1. Downgrade to an older version:
    yum downgrade docker-1.13.1-75.git8633870.el7.centos.x86_64 docker-client-1.13.1-75.git8633870.el7.centos.x86_64 docker-common-1.13.1-75.git8633870.el7.centos.x86_64
  2. Upgrade to a newer version, using Docker repository:
    https://docs.docker.com/install/linux/docker-ce/centos/#set-up-the-repository

After choosing either option docker restart should work.

420 Views