Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Question: We added the following settings to our knox topology so that knox may search in ldap for the groups that a user is in, so that we can efficiently control knox permissions with ranger.
Our search base and attribute settings are the same as those we have in our hadoop.security.ldap.group.mapping config, and for ranger. But in knox we get an error in the gateway.log (attached) complaining about the size of the results.
Normally the results are paginated, but it seems like knox is trying to get all of them at once. What do we need to change to make this work?
ERROR: Knox was searching in OUwhich has 3000 groups.
Below was setup -
1. Env has KNOX = AD integration in place
2. Env currently have 3000+ groups in AD and current limit for a search, without pagination, is 500.
3. User has Ranger -Knox plugin enabled.
4. User level policy for knox -ranger plugin works whereas it does not works if groups are specified in policy.