Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar

Tutorial Link

SandboxVersion: HDP 2.3.2
AmbariVersion2.1.2
Hadoop stack version:Hadoop2.7.1.2.3.2.0-2950

Issue 1: Error initializing SparkContext when executing spark-shell command

When you issue the command as root

spark-shell --master yarn-client --driver-memory 512m --executor-memory 512m

You would would receive the error:

ERROR SparkContext: Error initializing SparkContext.org.apache.hadoop.security.AccessControlException: Permission denied: user=root, access=WRITE, inode="/user/root/.sparkStaging/application_1451921066894_0001":hdfs:hdfs:drwxr-xr-x

Resolution

sudo su - hdfs
hdfs dfs -mkdir /user/root
hdfs dfs -chown root:hdfs /user/root
exit

--------------------------------------------------------

Issue 2

3,211 Views
Comments
avatar
Master Mentor

@Ancil McBarnett Whats the issue 2?

Please note, this tutorial is deprecated with HDP 2.4 release.

Version history
Last update:
‎01-04-2016 04:55 PM
Updated by:
Contributors