Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Initially I had installed hdp2.1 with ambari 1.7, then I upgraded ambari to 2.1.2 and upgraded hdp stack to 2.2.0.0 as per this documentation.
As per below note I had to delete STORM_UI_SERVER component:
"In HDP 2.2, STORM_REST_API component was deleted because the service was moved into STORM_UI_SERVER. When upgrading from HDP 2.1 to 2.2, you must delete this component using the API as follows"
It did not work because stop command did not complete successfully.
Error :
"message" : "org.apache.ambari.server.controller.spi.SystemException: An internal system exception occurred: Could not delete service component from cluster. To remove service component, it must be in DISABLED/INIT/INSTALLED/INSTALL_FAILED/UNKNOWN/UNINSTALLED/INSTALLING state
The only option was to remove this component completely from ambari database and restart ambari-server/agent procs.
Here is the short summary of what commands I ran:
[root@hdpambari ~]# psql ambari ambari
Password for user
ambari:
psql (8.4.20)
Type
"help" for help.
ambari=> delete from hostcomponentstate where component_name='STORM_REST_API';
DELETE 1
ambari=> delete from hostcomponentdesiredstate where component_name='STORM_REST_API';
DELETE 1
ambari=> delete from servicecomponentdesiredstate where component_name='STORM_REST_API';
DELETE 1
ambari=> commit;
WARNING: there is no transaction in progress
COMMIT
ambari=> \q
[root@hdpambari ~]#