Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
avatar
Master Guru

Initially I had installed hdp2.1 with ambari 1.7, then I upgraded ambari to 2.1.2 and upgraded hdp stack to 2.2.0.0 as per this documentation.

As per below note I had to delete STORM_UI_SERVER component:

"In HDP 2.2, STORM_REST_API component was deleted because the service was moved into STORM_UI_SERVER. When upgrading from HDP 2.1 to 2.2, you must delete this component using the API as follows"

I tried deleting it using ambari REST APIs:

First stop the component using below command:

curl -u admin:admin -X PUT -H 'X-Requested-By:1' -d '{"RequestInfo":{"context":"Stop Component"},"Body":{"HostRoles":{"state":"INSTALLED"}}}' http://hdpambari.hortonworks.com:8080/api/v1/clusters/c1/hosts/hdpambari.hortonworks.com/host_compon...

Then Delete using below curl call.

curl -u admin:admin -X DELETE -H 'X-Requested-By:1' http://hdpambari.hortonworks.com:8080/api/v1/clusters/hdpambari/services/STORM/components/STORM_REST...;

It did not work because stop command did not complete successfully.

Error :

"message" : "org.apache.ambari.server.controller.spi.SystemException: An internal system exception occurred: Could not delete service component from cluster. To remove service component, it must be in DISABLED/INIT/INSTALLED/INSTALL_FAILED/UNKNOWN/UNINSTALLED/INSTALLING state

The only option was to remove this component completely from ambari database and restart ambari-server/agent procs.

Here is the short summary of what commands I ran:

[root@hdpambari ~]# psql ambari ambari
Password for user
ambari:
psql (8.4.20)
Type
"help" for help.


ambari=> delete from hostcomponentstate where component_name='STORM_REST_API';
DELETE 1


ambari=> delete from hostcomponentdesiredstate where component_name='STORM_REST_API';
DELETE 1


ambari=> delete from servicecomponentdesiredstate where component_name='STORM_REST_API';
DELETE 1


ambari=> commit;
WARNING:  there is no transaction in progress
COMMIT
ambari=> \q
[root@hdpambari ~]#

This resolved my issue. hope this helps 🙂

2,214 Views
Version history
Last update:
‎11-05-2015 07:29 AM
Updated by:
Contributors