Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

3 Node Cluster, Nodes Disconnect

avatar
Contributor

Hello, I have a 3 node NiFi Cluster (nifi1, nifi2, and nifi3), using v 1.19.1.  

 

The nodes are each disconnecting consistently from the cluster.  They connect, and then disconnect, and then reconnect, and then disconnect over and over...

 

On nifi1, when I log into the GUI, a warning on the right side of the GUI indicates:

Event reported for nifi3:9443- Node disconnected from cluster due to Have not received a hearbeat from node in 338 seconds.

 

In the nifi GUI, logging into https://nifi1:9443/nifi, under the cluster section, when i first open this display,  no nodes are indicated as connected.  When I open the cluster window, an error message "Cannot replicate request to Node nifi1:9443 because the node is not connected.  Then, if I wait several minutes and refresh the screen, then all nodes are showing as connected, and then after another refresh nodes disconnect.

 

There is similar behavior when I log into https://nifi2:9443/nifi. I see a repeating error that includes nifi1, nif2 and nifi3...i.e., Event Reported for nifi3:9443 - Node disconnected from cluster due to Have not received a heartbeat from node in 1230 seconds, and these warning messages repeat with nifi1 and nifi3...

 

When I attempt to log into nifi3, i am unable.  I receive the following error message:

 

Cannot replicate request to Node nifi1:9443 because the node is not connected.

 

Can you please advise why this behavior is occurring.

 

 

1 ACCEPTED SOLUTION

avatar
Contributor

I solved my own issue.  

 

I corrected configuration settings in each respective zoo.cfg associated with each zookeeper host. The parameter Server.1 was erroneously pointing to each zookeeper host.  Replaced this with the private IP address of each nifi node.

 

 

View solution in original post

1 REPLY 1

avatar
Contributor

I solved my own issue.  

 

I corrected configuration settings in each respective zoo.cfg associated with each zookeeper host. The parameter Server.1 was erroneously pointing to each zookeeper host.  Replaced this with the private IP address of each nifi node.