Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Accessing the EKS cluster created as part of Data Warehouse Service in CDP.

avatar
Explorer

Hi,

I tried using the Data Warehouse service in my CDP account. What i came across is that Data Warehouse in the backend creates a EKS cluster in your AWS environment. But i was unable to access this EKS cluster using kubectl. Is this use case blocked or I am missing something. I tried accessing this EKS cluster with admin credentials of my AWS account but was still unable to access it. 

Can anyone help me with this.

1 ACCEPTED SOLUTION

avatar
Explorer

Hi @StevenOD ,

Thanks for your response. Turns out  I had to grant permission to my IAM user through the grant access option on the Data Warehouse UI.

Thanks.

View solution in original post

2 REPLIES 2

avatar
Super Collaborator

Hi @pky 

 

You can get the kubeconfig from your CDP environment configuration.

 

I'm hoping that this Community article might help you with your query:

 

https://community.cloudera.com/t5/Community-Articles/Cloudera-CDP-Data-Warehouse-Monitoring-How-to-g...

 

Regards,

Steve

avatar
Explorer

Hi @StevenOD ,

Thanks for your response. Turns out  I had to grant permission to my IAM user through the grant access option on the Data Warehouse UI.

Thanks.