Support Questions

Find answers, ask questions, and share your expertise

Ambari 2.5 deploy of hdp 2.6 faiils on RHEL 7 on libtirpc-devel libarary

New Contributor

Datanode install fails 2017-04-13 14:20:28,416 - Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_0_3_8-client' returned 1. Error: Package: hadoop_2_6_0_3_8-hdfs- (HDP-2.6)

           Requires: libtirpc-devel


@aakash bhatt

Try downloading the library "yum install libtirpc-devel -y", seems like that is whats is complaining about

New Contributor

That would not work, because none of the repos (EPEL,HDP Utils,RHEL Primary) have that library

RHEL has bug fix, cant see to find the rpm though

the one from rpmfind doesnt seem to work since it has other dependency mis-match

BTW it works in Centos/AWS AMI just fine, but we have RHEL 7 requirement

Did the documentation got a change?

RHEL 7.x is not present in supported OS section.

New Contributor

I also have this problem, does anyone have an answer to this question ?

@ Alexis..... Official Hortonworks documentation did not include RHEL 7.x as supported OS for HDP 2.6

New Contributor


Doesn't that mean that it is supported ? Anyway it also fails with HDP 2.5 with Error: Nothing to do

Oops it might be my mistake.

I will check and will get back to you.


There seems to be an confusion here:

Check in below link:

CentOS (64-bit)CentOS v7.xCentOS v6.xDebianDebian v7.xOracle (64-bit)Oracle Linux v7.xOracle Linux v6.xSUSE (64-bit)(SLES) Enterprise Linux 12, SP2 for Teradata(SLES) Enterprise Linux 12, SP1(SLES) Enterprise Linux 11, SP4 (HDP 2.2 and later)(SLES) Enterprise Linux 11, SP3 for Teradata (HDP 2.2 and later)(SLES) Enterprise Linux 11, SP1 (HDP 2.2)Ubuntu (64-bit)Ubuntu 16.04 (Xenial)Ubuntu 14.04 (Trusty)

There is no mention about RHEL7.x



It seems like below:

RHEL7.x is supported for HDP 2.6 but not for Ambari 2.5.x

New Contributor

ENV: OS: RHEL 7.3, Ambari and HDP 2.6

For this issue, we fixed by enabling following RHEL optional rpm repo.


This worked for me. The command to enable the optional repo is:

yum-config-manager --enable rhui-REGION-rhel-server-optional

Cloudera Employee


It works for me.

sudo yum-config-manager --enable rhui-REGION-rhel-server-optional
sudo yum install libtirpc-devel


Thank you - very useful!


Thanks, it worked for me !

Expert Contributor

that is not FREE I guess,

I m struggling with this for 2 hours, I can find free solution four this


@ Sreeni K... can you provide more details on how you resolved the issue

New Contributor

I had this problem earlier this month, after many fails, I resolved my problem by running the command below on each nodes of my cluster (ambari-server + ambari-agents) :

sudo yum install

I just pick up libtirpc-devel from a FTP repository and yum install it

If this works for you, you will most likely have to remove snappy and reinstal it on each nodes too :

sudo yum remove snappy

sudo yum install snappy-devel



New Contributor

I had the same issue. I fixed it by installing 'libtirpc-devel' package manually in all nodes.

wget rpm -i libtirpc-devel-0.2.1-11.el6.x86_64.rpm Note :- If you have 'libtirpc-0.2.1-11' already installed in your system. Make sure you download and install the same version of 'libtirpc-devel'

Ambari should have included this dependency package.


I had same issue on rhel 7 with below error


Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_6_3_0_235-hdfs' returned 1. Error: Package: hadoop_2_6_3_0_235-hdfs- (HDP-2.6-repo-101) Requires: libtirpc-devel You could try using --skip-broken to work around the problem

Solution :

Please check the Red Hat Enterprise Linux Server 7 Optional (RPMs) enabled on all nodes with below command

# yum repolist all (To check enabled or disabled)

!rhui-REGION-rhel-server-optional/7Server/x86_64 Red Hat Enterprise Linux Server 7 Optional (RPMs) Disabled:

#yum-config-manager --enable rhui-REGION-rhel-server-optional ( enabling the optional rpms)

Cross verify with first command to get it optional rpms enabled

# yum repolist all

!rhui-REGION-rhel-server-optional/7Server/x86_64 Red Hat Enterprise Linux Server 7 Optional (RPMs) enabled: 13,201