Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
01-07-2020
07:44 AM
- last edited on
01-07-2020
08:59 AM
by
VidyaSargur
Prv account part of AD group is not getting sync'd to Ambari and default access is not working.
2020-01-07T15:18:15.345Z, User(null), RemoteIp(10.176.18.143), Operation(User login), Roles(
), Status(Failed), Reason(Authentication required)
2020-01-07T15:18:15.346Z, User(null), RemoteIp(10.176.18.143), Operation(User login), Roles(
), Status(Failed), Reason(Invalid JWT token)
Normal lanid works fine and both are part of same AD group which has admin privileges.
the login is direct and not via knox , another weird thing noticed is prv works fine for knox login
Created 01-08-2020 01:11 AM
@jsensharma - I have managed to resolve the issue for my case it was an issue with ambary ldap sync which I had to run with the existing option and that did the trick .
So this can be marked as closed now.
Created 01-07-2020 07:46 AM
Just to add the LDAP sync for the AD group works fine for normal user and prv users doesn't reflect
Created 01-07-2020 01:34 PM
Which version of Ambari are you using ?
I see that there is a JIRA opened and addressed in Ambari 2.7.4 for addressing the "null" user appearing in "ambari-audit.log"
.
[JIRA] Ambari audit log shows "null" user when executing an API call : https://issues.apache.org/jira/browse/AMBARI-25234
Created 01-08-2020 01:11 AM
@jsensharma - I have managed to resolve the issue for my case it was an issue with ambary ldap sync which I had to run with the existing option and that did the trick .
So this can be marked as closed now.