Support Questions
Find answers, ask questions, and share your expertise

Ambari transport mode set to binary, but must connect using SASL

Solved Go to solution

Ambari transport mode set to binary, but must connect using SASL

I have "hive.server2.transport.mode" set to "binary", though when connecting to Hive via, for example, Tableau, I have to select "SASL" as the transport mode from within Tableau. Trying to connect with binary gives connection errors.

Is the "hive.server2.transport.mode" config not in effect, or is there something else at work that mat not seem intuitive?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari transport mode set to binary, but must connect using SASL

Master Collaborator

hive.server2.transport.mode values are either binary or http.

hive.server2.authentication – Authentication mode, default NONE. Options are NONE (uses plain SASL), NOSASL, KERBEROS, LDAP, PAM and CUSTOM.

Read more at https://cwiki.apache.org/confluence/display/Hive/Setting+Up+HiveServer2#SettingUpHiveServer2-Authent....

I believe Tableau is making you select the authentication mode and not the transport mode.

View solution in original post

1 REPLY 1

Re: Ambari transport mode set to binary, but must connect using SASL

Master Collaborator

hive.server2.transport.mode values are either binary or http.

hive.server2.authentication – Authentication mode, default NONE. Options are NONE (uses plain SASL), NOSASL, KERBEROS, LDAP, PAM and CUSTOM.

Read more at https://cwiki.apache.org/confluence/display/Hive/Setting+Up+HiveServer2#SettingUpHiveServer2-Authent....

I believe Tableau is making you select the authentication mode and not the transport mode.

View solution in original post