Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Authorization errors in Impala

avatar
Super Collaborator

Hello,

 

We have a strange issue here.

 

We are on CDH 6.3.0 and have sentry in place for authorizations. A user is trying to execute queries from Hue on Impala Editor and fails with Authorization errors. However, same query works fine via Hive and also via Impala shell. It fails only from Hue editor.

 

We have:

1. Refreshed metadata

2. Invalidated metadata

3. Verified permissions are in place in Sentry

4. There are no logs generated (I checked in Hue, Sentry Server and Catalog server). Please suggest if any other place should also be checked.

 

Example query:

select * from DB.table limit 5;

 

Kindly help to diagnose and resolve this issue.

 

Thanks

Snm1523

1 ACCEPTED SOLUTION

avatar
Master Collaborator

Hi,

 

1. What is the exact exception from Hue? Is this issue with all users or only specific users?

2. what is the sentry role you mapped to the database? can you check its privileges from below command. 

   ## SHOW GRANT ROLE <role-name> on database <database-name>;

3. check the group that user is belongs to:

    ## id <username>

4. check if the group is mapped to the sentry role, if not try to map the sentry role to group a user belong to and check the db access.

   ## GRANT ROLE <role_name> TO GROUP <groupName>;

 

View solution in original post

1 REPLY 1

avatar
Master Collaborator

Hi,

 

1. What is the exact exception from Hue? Is this issue with all users or only specific users?

2. what is the sentry role you mapped to the database? can you check its privileges from below command. 

   ## SHOW GRANT ROLE <role-name> on database <database-name>;

3. check the group that user is belongs to:

    ## id <username>

4. check if the group is mapped to the sentry role, if not try to map the sentry role to group a user belong to and check the db access.

   ## GRANT ROLE <role_name> TO GROUP <groupName>;