Support Questions

Find answers, ask questions, and share your expertise

Can not access cloudera WEB UI. After Installing it Successfully.

New Contributor

I Followed these steps :

 

First i took a server(Cent OS 6) from Google Cloud in Asia South reagion. and Executed these commands :

 

  1. sudo -i
  2. chkconfig iptables off
  3. service iptables stop
  4. setenforce 0
  5. vi /etc/selinux/config (SELINUX=disabled)
  6. init 6
  7. wget http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin
  8. chmod u+x cloudera-manager-installer.bin
  9. sudo ./cloudera-manager-installer.bin

Done! Cloudera manager installed Successfully.

But when I am trying to access http://my_public_ip:7180/ then getting timed out error.

Also i waited for almost an hour after installing cloudera(for startup settings). but again same response.

1 ACCEPTED SOLUTION

Expert Contributor

Hello Gaurav,

 

Please share the output of curl on http://my_public_ip:7180 from cm host itself.

 

And tcpdump from the source host.

View solution in original post

17 REPLIES 17

Super Guru

@Gaurav,

 

The first thing to check is whether the server is up and listening.

- service cloudera-scm-server status

- netstat -nap |grep 7180

 

Next, check the Cloudera Manager server log to find out if it had trouble starting.

- review /var/log/cloudera-scm-server/cloudera-scm-server.log

 

If you do find that Cloudera Manager is listening on 7180, make sure it is listening on all interfaces.

If you are getting a timed out message or a hang, that makes me suspicious that the server is coming up, but your route to that host is not working properly.  Could there be a proxy configured in your browser that cannot connect to your CM server?

You might try tcpdump or browser developer tools to find out what the client/server communication looks like.

 

I'd start with making sure the server is listening on 7180 and review the log for any exceptions or errors that look important.

 

New Contributor

Hi @bgooley,

 

Thankyou for response.

here what i got

 1. service cloudera-scm-server status

     Running

 

 2. netstat -nap |grep 7180

 

tcp        0      0 0.0.0.0:7180                0.0.0.0:*                   LISTEN      1623/java

 

 

and it seems that all right in log file.

Expert Contributor

Hello Gaurav,

 

Please share the output of curl on http://my_public_ip:7180 from cm host itself.

 

And tcpdump from the source host.

New Contributor

Thankyou @bgooley for the help.

 

I Just figured it out by tcpdump. now it's working.

Explorer

I am also facing the same issue, can you let me know how did you solve it

Super Guru

Hi @dewdrop,

 

Please see my initial comments in this thread.  We'll need to know more about what you try to do and what the result is.

 

Thanks,

 

Ben

Explorer

Hi,

 

I've installed cloudera Manager on Amazon VM Ec2 server.

 

disabled SELinux, disabled filewall setting

 

sudo service cloudera-scm-server status - up and running

 

netstat -nap |grep 7180
(No info could be read for "-p": geteuid()=1000 but you should be root.)
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN

 

i tried these two on the running server 

 

ec2-user@ip-172-31-44-224 ~]$ curl -i http://localhost:7180
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=sgoy1bydivup1kmcoqv110bfu;Path=/;HttpOnly
Content-Type: text/html; charset=utf-8
Last-Modified: Wed, 07 Feb 2018 17:44:18 GMT
Content-Length: 63
Accept-Ranges: bytes
Cache-Control: max-age=3600,public
Server: Jetty(6.1.26.cloudera.4)

<head><meta http-equiv="refresh" content="0;url=/cmf/"></head>

 

curl -i -u 'admin:admin' http://localhost:7180/api/v1/tools/echo
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=ubst7780j868jkzeysc0a31;Path=/;HttpOnly
Content-Type: application/json
Date: Wed, 28 Mar 2018 18:30:20 GMT
Transfer-Encoding: chunked
Server: Jetty(6.1.26.cloudera.4)

{
"message" : "Hello, World!"

}

both returned an output,

 

However when trying to access the below url from chrome or fixefox i am getting the below error

http://ip-172-31-44-224.us-west-2.compute.internal:7180

 

Error : 

We can’t connect to the server at ip-172-31-44-224.
If that address is correct, here are three other things you can try:

 

Any suggestions would be very helpful.

 

Thanks,

 

New Contributor
Hi @dewdrop,

Which Cloud Service are You using.
Have you allowed Port 7180 to access publicly?

Explorer
EC2 and port 7180 is open for public access

[ec2-user@ip-172-31-44-224 ~]$ netstat -na | grep 7180
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN

New Contributor
Hi @dewdrop,
It seems that you have opened the port 7180 on the EC2 Instance Firewall. But also you need to open TCP port 7180 in EC2 Security group.

How you can do this.
Go to the "Network & Security" -> Security Group settings in the left hand navigation
Find the Security Group that your instance is apart of
Click on Inbound Rules
Use the drop down and add port 7180
Click Apply.

Hope this helps!

Explorer
Hi,

Good morning, thanks for your reply,
I tried changing the setting as below but still it’s failing

Attached is the screenshot .

Thanks,

Explorer

I  changed the inbound rules to allow port 7180

 

still no luck.

Super Guru

@dewdrop,

 

If your browser cannot connect to ip-172-31-44-224.us-west-2.compute.internal:7180, then make sure that curl can connect  You tested with curl, but used "localhost" so the test was not as close a comparison as one would like.

 

Make sure that the ip-172-31-44-224.us-west-2.compute.internal hostname can be resolved to a proper IP address and that your host has a route to that IP address.

 

WireShark is a great tool decoding packets sent over the wire and can give you perspective about where the problem may be occurring

 

I'm not saying that it isn't firewalls or otherwise, but it would be good to clarify what is stopping the client from reaching the server host/port

Explorer

i tried replacing the localhost with the machine name and still works

 

 

[ec2-user@ip-172-31-44-224 ~]$ curl -i http://ip-172-31-44-224.us-west-2.compute.internal:7180
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=1h54xzygxge381p2g16fyh0wbh;Path=/;HttpOnly
Content-Type: text/html; charset=utf-8
Last-Modified: Wed, 07 Feb 2018 17:44:18 GMT
Content-Length: 63
Accept-Ranges: bytes
Cache-Control: max-age=3600,public
Server: Jetty(6.1.26.cloudera.4)

<head><meta http-equiv="refresh" content="0;url=/cmf/"></head>
[ec2-user@ip-172-31-44-224 ~]$ curl -i -u 'admin:admin' http://ip-172-31-44-224.us-west-2.compute.internal:7180/api/v1/tools/echo
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=1t1pb4wgxqsl61ix0fwo3c0xs5;Path=/;HttpOnly
Content-Type: application/json
Date: Wed, 28 Mar 2018 19:57:30 GMT
Transfer-Encoding: chunked
Server: Jetty(6.1.26.cloudera.4)

{
"message" : "Hello, World!"
}[ec2-user@ip-172-31-44-224 ~]$

Super Guru

@dewdrop,

 

So it does sound like the host is not accessible from your browser's network. 

Packet sniffing is a good way to help determine what is going on. 

EC2 support might know more.  This is an issue about network and packets and the cloud config, so talking to those who run it may help.

Explorer
Thanks a lot everyone who replied back to me to help, The cloudera cm
install went on fine and tats the reason I was able to connect the url
internally from the host machine, it’s a mistake from my end I grabbed the
private ip instead of the public ip and url failed, but when I used the
public ip was able to login to cloudera manager without any issues.

Thanks

Super Guru

@dewdrop,

 

No worries at all... we are just glad you got it working.  Nothing more frustrating then being stuck like you were!

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.