Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating a Century of Connection: Our Community Reaches 100,000 Members! Thank you!

Can not access cloudera WEB UI. After Installing it Successfully.

avatar
Explorer

I Followed these steps :

 

First i took a server(Cent OS 6) from Google Cloud in Asia South reagion. and Executed these commands :

 

  1. sudo -i
  2. chkconfig iptables off
  3. service iptables stop
  4. setenforce 0
  5. vi /etc/selinux/config (SELINUX=disabled)
  6. init 6
  7. wget http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin
  8. chmod u+x cloudera-manager-installer.bin
  9. sudo ./cloudera-manager-installer.bin

Done! Cloudera manager installed Successfully.

But when I am trying to access http://my_public_ip:7180/ then getting timed out error.

Also i waited for almost an hour after installing cloudera(for startup settings). but again same response.

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Hello Gaurav,

 

Please share the output of curl on http://my_public_ip:7180 from cm host itself.

 

And tcpdump from the source host.

View solution in original post

17 REPLIES 17

avatar
Explorer
Hi @dewdrop,
It seems that you have opened the port 7180 on the EC2 Instance Firewall. But also you need to open TCP port 7180 in EC2 Security group.

How you can do this.
Go to the "Network & Security" -> Security Group settings in the left hand navigation
Find the Security Group that your instance is apart of
Click on Inbound Rules
Use the drop down and add port 7180
Click Apply.

Hope this helps!

avatar
Explorer
Hi,

Good morning, thanks for your reply,
I tried changing the setting as below but still it’s failing

Attached is the screenshot .

Thanks,

avatar
Explorer

I  changed the inbound rules to allow port 7180

 

still no luck.

avatar
Master Guru

@dewdrop,

 

If your browser cannot connect to ip-172-31-44-224.us-west-2.compute.internal:7180, then make sure that curl can connect  You tested with curl, but used "localhost" so the test was not as close a comparison as one would like.

 

Make sure that the ip-172-31-44-224.us-west-2.compute.internal hostname can be resolved to a proper IP address and that your host has a route to that IP address.

 

WireShark is a great tool decoding packets sent over the wire and can give you perspective about where the problem may be occurring

 

I'm not saying that it isn't firewalls or otherwise, but it would be good to clarify what is stopping the client from reaching the server host/port

avatar
Explorer

i tried replacing the localhost with the machine name and still works

 

 

[ec2-user@ip-172-31-44-224 ~]$ curl -i http://ip-172-31-44-224.us-west-2.compute.internal:7180
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=1h54xzygxge381p2g16fyh0wbh;Path=/;HttpOnly
Content-Type: text/html; charset=utf-8
Last-Modified: Wed, 07 Feb 2018 17:44:18 GMT
Content-Length: 63
Accept-Ranges: bytes
Cache-Control: max-age=3600,public
Server: Jetty(6.1.26.cloudera.4)

<head><meta http-equiv="refresh" content="0;url=/cmf/"></head>
[ec2-user@ip-172-31-44-224 ~]$ curl -i -u 'admin:admin' http://ip-172-31-44-224.us-west-2.compute.internal:7180/api/v1/tools/echo
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=1t1pb4wgxqsl61ix0fwo3c0xs5;Path=/;HttpOnly
Content-Type: application/json
Date: Wed, 28 Mar 2018 19:57:30 GMT
Transfer-Encoding: chunked
Server: Jetty(6.1.26.cloudera.4)

{
"message" : "Hello, World!"
}[ec2-user@ip-172-31-44-224 ~]$

avatar
Master Guru

@dewdrop,

 

So it does sound like the host is not accessible from your browser's network. 

Packet sniffing is a good way to help determine what is going on. 

EC2 support might know more.  This is an issue about network and packets and the cloud config, so talking to those who run it may help.

avatar
Explorer
Thanks a lot everyone who replied back to me to help, The cloudera cm
install went on fine and tats the reason I was able to connect the url
internally from the host machine, it’s a mistake from my end I grabbed the
private ip instead of the public ip and url failed, but when I used the
public ip was able to login to cloudera manager without any issues.

Thanks

avatar
Master Guru

@dewdrop,

 

No worries at all... we are just glad you got it working.  Nothing more frustrating then being stuck like you were!