Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Cannot log into Ambari Dashboard for HDP2.5 Azure Sandbox


Created a new HDP2.5 Sandbox on Azure today. I can log into Ambari Dashboard for my old HDP2.4 Sandox using http://host:8080 or http://host:8888 but not with my new HDP2.5 one. It just times out. I tried ssh'g into my Sandbox to check if Ambari was running and/or start it manually but no luck. Any advice anyone?

[root@sandbox ~]# ambari-agent-password-reset
-bash: ambari-agent-password-reset: command not found

[root@sandbox ~]# ps -ef | grep Ambari
root 4772 1 2 18:53 ? 00:03:13 /usr/lib/jvm/java/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -XX:+CMSClassUnloadingEnabled -Xms512m -Xmx2048m -XX:MaxPermSize=128m -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/postgresql-jdbc.jar org.apache.ambari.server.controller.AmbariServer

root 7473 1 0 18:56 ? 00:00:00 /usr/bin/python /usr/lib/python2.6/site-packages/ambari_agent/ start
root 18654 18552 0 21:12 pts/1 00:00:00 grep --color=auto Ambari
[root@sandbox ~]# ambari-server start
-bash: ambari-server: command not found
[root@sandbox ~]# yum list | grep ambari-agent
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
[root@sandbox ~]# rpm -qa | grep ambari-server
[root@sandbox ~]#




@Suzanne Dimant, From the output of ps -ef | grep Ambari, It seems ambari server (pid=4772) and agent (pid=7473) are running. There has been few issues noticed in HDP2.5 sandbox regarding ambari login. Please follow below HCC thread.


Thanks yvora ... but I'm wondering ... if the server and agent are running then howcome the 'ambari-agent-password-reset' can't be found?


In order to ambari-agent-password-reset to work, the agent should be running fine. Can you please check ambari agent logs? You can find ambari-agent logs at /var/log/ambari-agent. Let's check if it has any error/exceptions.


yvora - There are no ambari logs at all in /var/log in my HDP2.5 VM; however they do exist in my HDP2.4 VM!

Trying to understand the 2 other questions you shared with me. The first seems to suggest I need to run 'ambari-agent-password-reset' as user hdfs, not root? Not clear on that. I've long since changed my root password, if that's all that's about?

The other one sounds promising but I'm having trouble understanding it. The Azure VM has a Docker container inside it? Wow! I thought they were competing technologies but I just found this announcement: ! So if I'm understanding correctly, I ssh in on port 2222 to log into the Docker container with the VM? Just tried that though and it didn't work (timed out). Same with 2122 (also mentioned in that post).


yes, that sounds right.


Unfortunately, all of the below variants time-out (where is my VM's static IP address). Should I not be using that IP address? FYI I posted a question on that Azure article I referenced above.

ssh -p 2222
ssh -p 2122
ssh -p 2222
ssh -p 2222


Found one tutorial for Azure Vms. Here they are using " ssh root@ -p 2222" . can you try that ?


In that tutorial, local host ( is for folks who have the Sandbox set up on a local VM (VMWare, VirtualBox, etc). It specifically says that "In case of Azure, your host can be found under Public IP Address on the dashboard." Further down in the document it says to use 'ssh <username>@<host> -p 22' to ssh into the Sandbox on Azure. Another document says to set up port-forwarding and log in as 'azure' but it doesn't tell you want azure's default password is so that doesn't 100% work:

@Suzanne Dimant

In one of your posts you linked to: and brought up an issue with the default password.

The password is the same one that you set up when originally deploying the sandbox on Azure. Additionally, the user ("azure" in the tutorial) is whatever user you specified during setup.

Hope that helps!


@Suzanne Dimant

To add: There are added security measures to HDP 2.5 on Azure, so you can SSH in just fine, but by default all other ports on Azure are closed. You can either open up the ports, or SSH tunnel (recommended) by following the tutorial above.


Thanks @Edgar Orendain ... I read those port-forwarding instructions too literally. Modified my ~./ssh/config using the username I created when I set up my Sandbox and was able to ssh in using the port-forwarding alias, however I still get ‘command not found’ when running ‘ambari-admin-password-reset’ as root.

After setting up port-forwarding, literally typing ‘http://localhost:8888' got me to the splash screen. When I clicked on ‘Launch Dashboard’ I got a log on screen and tried ever username/password combination I could think of. No luck. Also when I try ‘http://localhost:8080’ I get an error that my browser can’t connect.



most likely you have logged on as root from visualbox/vmware console to ssh to 22 port.

you need to ssh to 2222 or or web client

then you can reset the ambari asmin password by using


I am also seeing the same issues on my 2.5 version of Sandbox on Azure.I am a new user to both Azure, HDP Sandbox and i was not expecting this, also i wonder why we don't have AWS based HDP sandbox?

  1. ambari-agent-password-reset
  2. -bash: ambari-agent-password-reset: command not found
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.