Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Configuration Steps for Central Repository of Zeppelin Notebooks in a Multi-Node Environment


I have installed Zeppelin Notebooks on two nodes in a Ambari Managed HDP Cluster using the link. Both the links are up and running. User authentication is enabled via LDAP users.

When a user is creating a notebook on Node 1, the notebook is not visible when he logs in from URL-of node 2. is enabled.

The version of Zeppelin is 0.7.3

Is it possible to use - HDFS file system location as the repository path for Zeppelin notebooks and where do I configure the path for Zeppelin, so that both nodes point to the same repo.




Super Collaborator
@Bhanu Pamu

Please refer to the following section of our documentation to enable HDFS storage for Zeppelin HA:


I followed the above steps. The configuration in Ambari --> Zeppelin Notebook--> Configs --> Advanced zeppelin-config

  • zeppelin.config.fs.dir=conf
  • zeppelin.notebook.dir=notebook
  • zeppelin.interpreter.dir=interpreter

Yet while I login to Zeppelin Notebook to either of the nodes - the Notebook Repos tab shows the following value

Notebook Path/usr/hdp/current/zeppelin-server/notebook/

So whenever I create a notebook, it goes and saved in local zeppelin server directory.

I tried changing the path of Network Repos from Zeppelin login, however when I restart the services, it goes back to default.

I tried changing the value of ZEPPELIN_NOTEBOOK_DIR in zeppelin_env_content using Ambari, however the after service restart Zeppelin doesn't work properly. It gives 503 server error or the notebooks repo is empty, no old notebooks seen. I have copied the notebooks from /usr/hdp/current/zeppelin-server/notebook/local to hdfs file system /user/zeppelin/notebook, still no gain.

Somehow the configuration doesn't work in HA mode. The notebook files are not written to HDFS file system.

Any further suggestions?

New Contributor

same issue. It seems like Notebook Path is not getting persisted in the config anywhere.



The above question and the entire response thread below were originally posted in the Community Help track. On Sun Jul 21 23:35 UTC 2019, a member of the HCC moderation staff moved it to the Data Science & Advanced Analytics track. The Community Help Track is intended for questions about using the HCC site itself.

Bill Brooks, Community Moderator
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.