Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Embedded zookeeper failing while setting up a three node cluster

avatar
Not applicable

Embedded zookeeper is failing to start while setting up a three node cluster for NIFI.

The error message indicates that there is an issue with starting the embedded Zookeeper server while starting NiFi on your three-node cluster. The specific error causing the problem is "Address already in use," which suggests that the port required by Zookeeper is already occupied by another process. How can I solve this issue?

 

 

1 REPLY 1

avatar

@Former Member,

First of all, make sure that nothing is running on the port 2182, as this is the port used by the embedded Zookeeper by default. It could be that you changed it, but my initial feeling is that you left it as it is.

Secondly, make sure that you wrote the correct zookeeper connection string within state-management.xml and within each nifi.properties.