Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error enabling auto tls on cdp 7.1.8

avatar

Im on CM 7.10.1, cloudera runtime 7.1.8. I am trying to enable auto tls after creating the cluster, after i input ssh credentials (which are correct), I am getting error "java.lang.IllegalStateException: Failed to run CMCA command, return code: 2"

 

More info: I have enabled kerberos but have not enabled auto tls yet

 

Could someone please guide me on how to troubleshoot this issue?

4 REPLIES 4

avatar

skylarblu4650_0-1705935324918.png

Update: I tried setting up the cluster again and enabling auto TLS at cluster creation, facing same error as per screenshot above 

avatar
Master Collaborator

Hello @skylarblu4650 

You might need to check /var/log/cloudera-scm-server/cloudera-scm-server.log to get a clue regarding the error that you are facing.

Also just an FYI 7.10.1 is specifically for the CDP private  cloud data services cluster https://supportmatrix.cloudera.com/

avatar
Super Collaborator

 skylarblu4650

also, check the certmanager.log under the agent log directory, which should contain an exception for this issue.

 

avatar
Explorer

This occurs in two scenarios

1. Jdk-11 installed but not provided mod 777
2. jdk-11 not properly extracted and moved 

install openjdk11

download the file openjdk-11_linux-x64_bin.tar to /tmp
tar -xf openjdk-11_linux-x64_bin.tar
mv /tmp/jdk-11 /usr/lib/jvm
chmod 777 /usr/lib/jvm/jdk-11

update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk-11/bin/java" 1010
update-alternatives --install "/usr/bin/javac" "javac" "/usr/lib/jvm/jdk-11/bin/javac" 1010
verify > java -version & javac -version

restart cloudera-scm-server