Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-29-2022 05:31 PM
We upgraded from 7.1.6 to 7.1.7 GA and had similar issue and now we are trying to upgrade to hotfix and facing same issue and a bit unclear what fixed the first issue !
We copied the following files to /opt/cloudera/parcel-repo
8549720983 Jan 29 00:10 CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel
40 Jan 30 00:44 CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel.sha1
64 Jan 30 00:44 CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel.sha256
When we check parcels in CM we see the following Error
| CDH 7 | 7.1.7-1.cdh7.1.7.p74.21057765 | Unavailable | |
|
We tried copying the SHA files again ...compared bits with another download and still same error . Anything we are missing ? Is there supposed to be a "torrent" file ? Couldnt see it in archive .
Created 02-09-2022 09:26 PM
Hi, @Sam2020 ,
Run the following and try again:
mv \
/opt/cloudera/parcel-repo/CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel.sha1 \
/opt/cloudera/parcel-repo/CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel.sha
chown cloudera-scm:cloudera-scm/opt/cloudera/parcel-repo/*
Please let me know if this helped.
Cheers,
André
Created 02-09-2022 09:26 PM
Hi, @Sam2020 ,
Run the following and try again:
mv \
/opt/cloudera/parcel-repo/CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel.sha1 \
/opt/cloudera/parcel-repo/CDH-7.1.7-1.cdh7.1.7.p74.21057765-el7.parcel.sha
chown cloudera-scm:cloudera-scm/opt/cloudera/parcel-repo/*
Please let me know if this helped.
Cheers,
André
Created 02-27-2022 09:59 PM
Hi Sam2020,
Just wanna add,I encounter this issue as well. Got the exact same error while downloading the parcel from Cloudera Manager. Im using local/internal repository.
My permission on /opt/cloudera/parcel-repo is already cloudera-scm without any modification needed. And the sha file also does not have 1 or 256 at the end.
What I did was:
1.Remove old unused 7.1.7 p0 parcels.
2.Restart CM server
3.Redownload 7.1.7 p74 from CM UI.
*Im on cdh 6 planning to upgrade to 7.1.7 p74 without doing the 7.1.7 p0
*I do realize that all other parcels including 7.1.7 p0 have .torrent file except this 7.1.7 p74. Not sure if that have anything to do with it