Support Questions
Find answers, ask questions, and share your expertise

Error in kudu logs, unable to use kudu

Solved Go to solution
Highlighted

Error in kudu logs, unable to use kudu

Explorer

I am unable to use Kudu and getting some error messages:

 

[cloudera@quickstart kudu]$ sudo cat /var/log/kudu/kudu-master.FATAL
Log file created at: 2017/08/23 15:32:16
Running on machine: quickstart.cloudera
Log line format: [IWEF]mmdd hh:mm:ss.uuuuuu threadid file:line] msg
F0823 15:32:16.151196 5485 hybrid_clock.cc:227] Couldn't get the current time: Clock unsynchronized. Status: Service unavailable: Error: Clock synchronized but error wastoo high (10000016 us).

 

[cloudera@quickstart kudu]$ kudu -version
kudu 1.4.0-cdh5.12.0
 

[cloudera@quickstart kudu]$ hadoop version
Hadoop 2.6.0-cdh5.10.0

Any help?

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error in kudu logs, unable to use kudu

Rising Star

No, --max_clock_sync_error_usec is a Kudu parameter, not an ntp parameter. You need to reconfigure Kudu to use it.

 

See the Kudu documentation and the Cloudera Manager documentation to learn how to reconfigure Kudu.

 

View solution in original post

5 REPLIES 5
Highlighted

Re: Error in kudu logs, unable to use kudu

Rising Star

The Kudu documentation on the subject suggests your ntp installation may need some troubleshooting. Interestingly, the max error you're seeing (10,000,016 microseconds or just past 10 seconds) is very close to the max error allowable (exactly 10 seconds). What you could do is configure your Kudu service with something like --max_clock_sync_error_usec=11000000 (11 seconds), and that should be good enough for your ntp installation. You'd need to put this in the Kudu service's safety valve configuration since --max_clock_sync_error_usec is not exposed as a first class configuration parameter in CM.

Highlighted

Re: Error in kudu logs, unable to use kudu

Champion

@Adar if we dont have to use safety valve just curious to know which config file that it has to go 

--max_clock_sync_error_usec = ? or we increase the flag is there a command line 

Highlighted

Re: Error in kudu logs, unable to use kudu

Rising Star
--max_clock_sync_error_usec is a Kudu gflag parameter, which means it can be passed on the command line (i.e. 'kudu-tserver --fs_wal_dir=... --fs_data_dirs=... --max_clock_sync_error_usec=...'), or it can be included in a gflagfile (i.e. 'kudu-tserver --gflagfile=/path/to/file', then /path/to/file is a file containing "--max_clock_sync_error_usec=..." along with other parameters, each on its own line).

If you're managing Kudu with CM, there's no way to feed this parameter into Kudu except via the gflagfile safety valve.
Highlighted

Re: Error in kudu logs, unable to use kudu

Explorer

Should I put below value in /etc/profile?

 

sudo /etc/init.d/ntpd restart --max_clock_sync_error_usec=11000000

Re: Error in kudu logs, unable to use kudu

Rising Star

No, --max_clock_sync_error_usec is a Kudu parameter, not an ntp parameter. You need to reconfigure Kudu to use it.

 

See the Kudu documentation and the Cloudera Manager documentation to learn how to reconfigure Kudu.

 

View solution in original post

Don't have an account?