Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error nifi cluster in kubernetes

avatar

I'm having a problem trying to create a nifi cluster with kubernetes.

Error displayed: "The specified run.as user ec2-user does not exist. Exiting."

The error appears when I use /opt/nifi/nifi-current/conf folder mapping
If I remove this mapping from the nifi folder, the cluster is created without problems.
But I need this folder to keep the data flows if the container dies, come back with the data

the folder in the instance is in /home/ec2-user/user/1.16

I already gave permission 777 on the folder to test and it still didn't work

I already changed the user to upload with root user and nifi (pid 0 and 1000) and it didn't work

1 ACCEPTED SOLUTION

avatar

Find out the problem.
It seems that in versions above 1.14 the bootstrap.conf file has an option in the ^M file
where you can change the file parameters


photo1649687275.jpeg

I removed this option in the value "Run.as"
and the problem was solved

View solution in original post

1 REPLY 1

avatar

Find out the problem.
It seems that in versions above 1.14 the bootstrap.conf file has an option in the ^M file
where you can change the file parameters


photo1649687275.jpeg

I removed this option in the value "Run.as"
and the problem was solved