Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error when grant user permissions in HBase: HTTP 403 Error: Grantee user txw387 doesn't exist

avatar
Contributor

I want to grant user 'txw387' RWC permissions. There is a hadoop folder 'txw387' under /user.

However, this error occurs: 

ERROR: org.apache.hadoop.hbase.coprocessor.CoprocessorException: HTTP 403 Error: Grantee user txw387 doesn't exist
at org.apache.ranger.authorization.hbase.RangerAuthorizationCoprocessor.preGrant(RangerAuthorizationCoprocessor.java:1277)
at org.apache.ranger.authorization.hbase.RangerAuthorizationCoprocessor.preGrant(RangerAuthorizationCoprocessor.java:1110)
at org.apache.hadoop.hbase.master.MasterCoprocessorHost$164.call(MasterCoprocessorHost.java:1892)
at org.apache.hadoop.hbase.master.MasterCoprocessorHost$164.call(MasterCoprocessorHost.java:1889)
at org.apache.hadoop.hbase.coprocessor.CoprocessorHost$ObserverOperationWithoutResult.callObserver(CoprocessorHost.java:558)
at org.apache.hadoop.hbase.coprocessor.CoprocessorHost.execOperation(CoprocessorHost.java:631)
at org.apache.hadoop.hbase.master.MasterCoprocessorHost.preGrant(MasterCoprocessorHost.java:1889)
at org.apache.hadoop.hbase.master.MasterRpcServices.grant(MasterRpcServices.java:2721)
at org.apache.hadoop.hbase.shaded.protobuf.generated.MasterProtos$MasterService$2.callBlockingMethod(MasterProtos.java)
at org.apache.hadoop.hbase.ipc.RpcServer.call(RpcServer.java:387)
at org.apache.hadoop.hbase.ipc.CallRunner.run(CallRunner.java:139)
at org.apache.hadoop.hbase.ipc.RpcExecutor$Handler.run(RpcExecutor.java:369)
at org.apache.hadoop.hbase.ipc.RpcExecutor$Handler.run(RpcExecutor.java:349)

For usage try 'help "grant"'

 

How to solve this problem?

1 ACCEPTED SOLUTION

avatar
Master Collaborator

Hi @MaraWang 

The error indicates you are using ranger to manage the permissions on hbase. Try to open the ranger WebUi and add the permissions for user under hbase policy.

 

Also, verify if the user 'txw387' exists in your cluster

Ref-

https://docs.cloudera.com/runtime/7.2.18/security-ranger-authorization/topics/security-ranger-resour...

View solution in original post

4 REPLIES 4

avatar
Community Manager

@shubham_sharma @pajoshi @smdas Hi! Do you have any insights here? Thanks!


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Master Collaborator

Hi @MaraWang 

The error indicates you are using ranger to manage the permissions on hbase. Try to open the ranger WebUi and add the permissions for user under hbase policy.

 

Also, verify if the user 'txw387' exists in your cluster

Ref-

https://docs.cloudera.com/runtime/7.2.18/security-ranger-authorization/topics/security-ranger-resour...

avatar
Super Collaborator

Hi @MaraWang it seems like the user itself is not present in ranger, you need to sync the user from your sync source for ranger, and after that, you need to prove RWX access on hdfs path "/user" under ranger -> cm_hdfs repo, either create a new policy for this or add into an existing one.

avatar
Community Manager

@MaraWang 

Have you been able to resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. 

Screen Shot 2019-08-06 at 1.54.47 PM.pngmark as solution button

Keep the questions coming