Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 08-08-2019 05:53 PM - edited 09-16-2022 07:32 AM
The hdfs installation fails with the following error while installing cdh 6.2.
Can't open /var/run/cloudera-scm-agent/process/63-hdfs-NAMENODE-format/supervisor_status:Permission denied
what would cause this error?
Created 08-12-2019 11:06 AM
The error message regarding the supervisor_status file can be ignored. We will fix the code that generates that error sometime in the future.
The message that indicates the cause of the formatting failure is:
Running in non-interactive mode, and data appears to exist in Storage Directory /dfs/nn.
Not formatting.
It may be you have some old data in /dfs/nn. If you are sure you do not need what is in /dfs/nn you can copy it to another location or delete it. Just be sure you don't need/want whatever is there.
Created 08-12-2019 10:36 AM
Can't open /var/run/cloudera-scm-agent/process/67-hdfs-NAMENODE-format/supervisor_status: Permission denied.
+ make_scripts_executable
+ find /var/run/cloudera-scm-agent/process/67-hdfs-NAMENODE-format -regex '.*\.\(py\|sh\)$' -exec chmod u+x '{}' ';'
+ '[' DATANODE_MAX_LOCKED_MEMORY '!=' '' ']'
+ ulimit -l
+ export HADOOP_IDENT_STRING=hdfs
+ HADOOP_IDENT_STRING=hdfs
+ '[' -n '' ']'
+ '[' mkdir '!=' format-namenode ']'
+ acquire_kerberos_tgt hdfs.keytab
+ '[' -z hdfs.keytab ']'
+ KERBEROS_PRINCIPAL=
+ '[' '!' -z '' ']'
+ '[' -n '' ']'
+ '[' validate-writable-empty-dirs = format-namenode ']'
+ '[' file-operation = format-namenode ']'
+ '[' bootstrap = format-namenode ']'
+ '[' failover = format-namenode ']'
+ '[' transition-to-active = format-namenode ']'
+ '[' initializeSharedEdits = format-namenode ']'
+ '[' initialize-znode = format-namenode ']'
+ '[' format-namenode = format-namenode ']'
+ '[' -z /dfs/nn ']'
+ for dfsdir in '$DFS_STORAGE_DIRS'
+ '[' -e /dfs/nn ']'
+ '[' '!' -d /dfs/nn ']'
+ CLUSTER_ARGS=
+ '[' 2 -eq 2 ']'
+ CLUSTER_ARGS='-clusterId cluster19'
+ '[' 3 = 6 ']'
+ '[' -3 = 6 ']'
+ exec /opt/cloudera/parcels/CDH-6.2.0-1.cdh6.2.0.p0.967373/lib/hadoop-hdfs/bin/hdfs --config /var/run/cloudera-scm-agent/process/67-hdfs-NAMENODE-format namenode -format -clusterId cluster19 -nonInteractive
WARNING: HADOOP_PREFIX has been replaced by HADOOP_HOME. Using value of HADOOP_PREFIX.
WARNING: HADOOP_NAMENODE_OPTS has been replaced by HDFS_NAMENODE_OPTS. Using value of HADOOP_NAMENODE_OPTS.
Running in non-interactive mode, and data appears to exist in Storage Directory /dfs/nn. Not formatting.
Created 08-12-2019 11:06 AM
The error message regarding the supervisor_status file can be ignored. We will fix the code that generates that error sometime in the future.
The message that indicates the cause of the formatting failure is:
Running in non-interactive mode, and data appears to exist in Storage Directory /dfs/nn.
Not formatting.
It may be you have some old data in /dfs/nn. If you are sure you do not need what is in /dfs/nn you can copy it to another location or delete it. Just be sure you don't need/want whatever is there.
Created on 08-12-2019 11:52 AM - edited 08-12-2019 11:56 AM
thanks