Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
06-15-2019
08:00 AM
- last edited on
06-16-2019
04:58 AM
by
cjervis
Facing this issue with the namenode down. It is a parcel based CDH 5.15.2 installation on AWS.
| 9:15:18.262 PM | ERROR | NameNode |
Failed to start namenode. java.io.FileNotFoundException: File does not exist: /user/spark/spark2ApplicationHistory/.5e9b4c52-032a-4469-b278-80aa6254cfdf at org.apache.hadoop.hdfs.server.namenode.INodeFile.valueOf(INodeFile.java:66) at org.apache.hadoop.hdfs.server.namenode.INodeFile.valueOf(INodeFile.java:56) at org.apache.hadoop.hdfs.server.namenode.FSEditLogLoader.applyEditLogOp(FSEditLogLoader.java:429) at org.apache.hadoop.hdfs.server.namenode.FSEditLogLoader.loadEditRecords(FSEditLogLoader.java:232) at org.apache.hadoop.hdfs.server.namenode.FSEditLogLoader.loadFSEdits(FSEditLogLoader.java:141) at org.apache.hadoop.hdfs.server.namenode.FSImage.loadEdits(FSImage.java:903) at org.apache.hadoop.hdfs.server.namenode.FSImage.loadFSImage(FSImage.java:756) at org.apache.hadoop.hdfs.server.namenode.FSImage.recoverTransitionRead(FSImage.java:324) at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.loadFSImage(FSNamesystem.java:1152) at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.loadFromDisk(FSNamesystem.java:799) at org.apache.hadoop.hdfs.server.namenode.NameNode.loadNamesystem(NameNode.java:614) at org.apache.hadoop.hdfs.server.namenode.NameNode.initialize(NameNode.java:676) at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:844) at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:823) at org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:1547) at org.apache.hadoop.hdfs.server.namenode.NameNode.main(NameNode.java:1615) |
| 9:15:18.264 PM | INFO | ExitUtil |
Exiting with status 1 |
| 9:15:18.265 PM | INFO | NameNode |
SHUTDOWN_MSG: /************************************************************ SHUTDOWN_MSG: Shutting down NameNode at xxxx.xxxx.xxxx/**.**.**.** ************************************************************/ |
Stuck from two days. Any help will be highly appreciated.
Cheers,
Created 06-23-2019 08:37 PM
Created 06-18-2019 04:57 AM
Hi @urbanlad20,
Your error is:
File does not exist: /user/spark/spark2ApplicationHistory/.5e9b4c52-032a-4469-b278-80aa6254cfdf
Can you restart the spark installation ? it seems to be related.
Regards,
Manu.
Created 06-21-2019 05:27 AM
Created 06-21-2019 09:03 AM
That stack reminds me of HDFS-12369 but I also thought it should be fixed in CDH 5.12.2.
I think it would be good to have HDFS folks look at this; I'll move thread to HDFS.
Created 06-23-2019 08:37 PM