Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-15-2019 11:57 AM
On a perfectly running HDP3.1 cluster, one time the ATSv2 Timeline Reader stopped responding. Following some guide I've tried refreshing the service by cleaning the configs and restarting it by
yarn app -destroy ats-hbase
After this, restarting the service doesn't help, and starting the service by
yarn app -start ats-hbase
doesn't work, since the config json is missing:
ERROR client.ApiServiceClient: File does not exist: <>/user/yarn-ats/.yarn/services/ats-hbase/ats-hbase.json
What is this .json and how do I get it running again? Where are some example templates of a working .json that I could use? I remember this file existing somewhere on a fresh install, but sadly reinstall of the cluster is not an option. Another thing, trying a fresh install on my laptop VM does not create such json file too -- I guess the reason is that the laptop is too small for enforcing hbase use?
Didn't find anything in the official documentation, so would be thankful for any advice!
Created 07-15-2019 12:04 PM
@Javert Kirilov The config json of ats-hbase should be created on startup of ResourceManager. If it wasn't created, then check the logs of the ResourceManager for any errors related to ats-hbase while starting up.
Created 07-15-2019 12:04 PM
@Javert Kirilov The config json of ats-hbase should be created on startup of ResourceManager. If it wasn't created, then check the logs of the ResourceManager for any errors related to ats-hbase while starting up.
Created 07-15-2019 12:19 PM
Thanks for clarifying. It was indeed recreated after a full restart.
Though, I'm noticing tons of errors, hope these are related to a slow start of all the services.