Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

Solved Go to solution

HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

Explorer

I have a cluster managed using CM5.0 and has both mapreduce and Yarn installed and running. I want to make oozie to submit jobs to yarn rather than mapreduce. So in Oozie configuration through Cloudera Manager, changed the mapreduce properties to yarn so that oozie can submit all jobs to Resorce manager. But when I submit the workflow defined in oozie (through hue) it is still submiting the jobs to jobTracker and showing the below error,

 

HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

 

How I can make Oozie to automatically pick yarn configurations (hostname:8032) so that it is submitted to Resource manager? Someone's help will be greatly appreciated!! Thanks in advance.  

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

New Contributor

Thanks for valuable information . I have fixed the above issue by changing the MapReduce Service property value in hive configuration file to Yarn.

5 REPLIES 5

Re: HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

Master Guru
Do you perhaps have safety valve overrides in your Hue Configuration page in CM that is setting the default mapred_clusters to a MR1 location?

If so, please remove them away since you have switched over to YARN now. Doing that will resolve it.

Also ensure that Hue's MapReduce Cluster setting is set to your YARN service and not the MR1 service.
Highlighted

Re: HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

Explorer

Thanks Harsh,

 

I checked it out earlier for safety valve, but it is empty. This is a newly installed cluster, defaulty the mapred property in oozie is set to mapreduce and I changed it to Yarn. In mapreduce mode jobs are executing but in Yarn mode it is throwing this error.

Re: HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

Master Guru
If its of any help, the error is sourced from the client's values. The client here is Hue, which is sending the jobtracker value for the WF as the MR1 URL instead of the MR2 RM one.

As a result, since the Oozie server is pre-tuned to only talk to YARN service, it rejects the client (Hue) cause its passed JT location is invalid for the current whitelist of RMs.

You should look further into why Hue is still sending the MR1 properties along, instead of MR2. Perhaps the values are embedded into the WF application, or perhaps the Hue service has not been configured to also talk to the YARN service (via its CM Hue Configuration page, just like how you switched Oozie to talk to YARN).

The Oozie server isn't at fault here.

Re: HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

Contributor

IIRC, for Hue to switch between MR1 and MR2, you have to ensure that a few of the other services are also switched.  For example, in CM's Hive configuration page, I believe it has a similar config property to Oozie's that lets you switch between MR1 and MR2.  Make sure they are both set to MR2.  You should also check if any other services have a similar property.  Then restart Hue, of course.

Software Engineer | Cloudera, Inc. | http://cloudera.com

Re: HadoopAccessorException: E0900: Jobtracker [hostname:8021] not allowed, not in Oozie

New Contributor

Thanks for valuable information . I have fixed the above issue by changing the MapReduce Service property value in hive configuration file to Yarn.