Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Has anyone installed the minifi C2 ( command and control ) . I need some steps to get this working. Do we have an installation document for this.

Expert Contributor

Has anyone installed the minifi C2 ( command and control ) . I need some steps to get this working. Do we have an installation document for this. I have got my minifi agents on two separate servers which transmit data to the Nifi Server. I plan to create a C2 Server which will co-ordinate with the minifi agents installed on different machines. I have a high level idea of what C2 will do , but in the absence of any documents , its a bit difficult for me to progress. Need some help here .

@Vinicius Higa Murakami , @Shu , @Pierre Villard , @Matt Burgess , @Matt Clarke

Have you worked on this by any chance or provide any inputs to this.




i found the guidelines from "How to build an IIoT system using Apache NiFi, MiNiFi, C2 Server, MQTT and Raspberry Pi" written by Abdelkrim Hadjidj use full

the basic start command : "/bin/", make sure you have the configuration correctly

i also found an Jira Issue solution for version 0.4

By removing the file from lib directory in 0.4.0 version, it works
as expected.

View solution in original post


Expert Contributor

Hey @Raymond Honderdors .. all good mate. This issue is now fixed. I had to rename my template to have the suffix .v1. I ignored that which is why I wasnt getting the config.yml . Its all sorted now and its working fine.

Thanks again for all your help


Hi Abhinav,Did u receive below error while working on above implementation

o.a.n.m.b.c.i.PullHttpChangeIngestor Hit an exception while trying to pull Failed to connect to /

Expert Contributor

@Vipin Chourasia I reckon this might be a firewall issue or something . I remember seeing something like this and then realized the firewall wasnt opened between the C2 server and the Minifi server


I checked both the windows system ,firewall is open .checked by using ping coomand.


Hi Abhinav, I am doing the same POC connect MINIFI NIFI using minifi c2 .Could you please guide us on this .As of now we have done minifi to nifi connectivity-Receiving data to nifi end , generated from minifi agent but now have to use minifi c2 controller.Please help buddy.

What i have understood Minifi c2 and nifi should be in same machine and minifi in another machine(windows)

then did some configuration changes and try to run minifi c2 but getting error .

I am following below link


I follow the steps.

1. downloaded minif c2 server in windows where my nifi is running.

2.created a template using nifi ui with name given examplename iot-minifi-raspberry-agent.v1

3.changed minifi c2 property port -8080 (i was also getting port 10080 is already in use)

4.changed minifi-c2-context.xml property

----> <constructor-arg> <value>http://localhost:9090/nifi/</value> </constructor-arg> in this url my nifi is working,so this only changed minifi is running in different windows machine there i changed bootstrap property like below


# Hostname on which to pull configurations from


# Port on which to pull configurations from


# Path to pull configurations from


# Query string to pull configurations with

nifi.minifi.notifier.ingestors.pull.http.query=class=iot-minifi-raspberry-agent ----// name of my template ?? should i use version also like .v1

# Period on which to pull configurations from, defaults to 5 minutes if commented out

-----------------------------------*****------------------- all changes are done now checking whether my changes are done correctly by hitting below url --


I can see yml is showing but that is already present in minifi c2 -->files folder ,

how my template's yml will create.where i m doing wrong or my understanding is incorrect .Please help @Raymond Honderdors @Abhinav Joshi @Bryan Bende

Any help would be really appreciated.Thanks in advance

Expert Contributor

Hi @Vipin Chourasia ..apologies , for not being able to respond earlier . I have prepared a document to go through all this . Its a big document , can you give me your email id . I will flick it through .. I also went through the same issues but now our C2 is working very well.


Thanks for reply Abhinav.You can't imagine how much relax i am feeling now .I was chashing you from many days.even i have tried to contact Abdelkrim Hadjidj for // 


The current status of my POC is - I am able to create data flow between minifi(more than 2 system )and NIFI but stuck in C2 server configuration. I have done setup in windows machine.Thanks again Abhi

New Contributor

I am struck at configuring the C2 server. Is it possible to share the document. 

Expert Contributor

Hi @Vipin Chourasia . sorry mate . I know this is something that is very new and there is hardly any material out there . I also chased Abdelkrim 🙂 but didnt get any response. hahaha. Anyways .. sent you the document now. Have a read through