Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

How do I resolve clock offset issue?

Solved Go to solution
Highlighted

How do I resolve clock offset issue?

Explorer

I get following health issue.

 

The host's NTP service did not respond to a request for the clock offset.

 

How do I resolve it?

 

Thanks,

Kewal

1 ACCEPTED SOLUTION

Accepted Solutions

Re: How do I resolve clock offset issue?

Explorer

Yes, the problem was at the Firewall , one of the rules was changes ;

after the problem was fix the NTP was updated.

 

Thanks so much for your help

18 REPLIES 18

Re: How do I resolve clock offset issue?

I just saw this after an office move. The servers were offline for a while.

 

This is what I did for our CentOS Linux servers (similar, but not the same, steps would work for Ubuntu/Debian):

 

* verified/updated the /etc/ntp.conf file to be the same across the cluster

* stopped the ntp daemon: /etc/init.d/ntpd stop

* connected to the ntp server named in the ntp.conf file: ntpupdate <ntp_server>

* started the ntp daemon: /etc/init.d/ntpd start

* added ntpd to the startup manager: chkconfig add ntpd

* set ntpd to start in default reunlevels: chkconfig ntpd on

 

This cleared the offset issue. If this doesn't do it for you, you might also have to look into drift, or dig deeper into the time synchronization.

 

 

Re: How do I resolve clock offset issue?

Explorer

Thanks a lot for you detailed answer. 

 

I deleted the cluster and rebuilt it from scratch. Now, it is working fine.(Fingers crossed)

 

But, It seems, your procedure would definitely solve the problem.

Re: How do I resolve clock offset issue?

New Contributor

Thanks for your detailed answer. it helped me! 

 

I had to repeat the step 4 and 5 twice; but it fixed my issue. I'm keeping the fingers crossed now! :) 

Re: How do I resolve clock offset issue?

New Contributor

Many thanks. I followed these  steps and it fixed my clock offset issue.

 

* verified/updated the /etc/ntp.conf file to be the same across the cluster

* stopped the ntp daemon: /etc/init.d/ntpd stop

* connected to the ntp server named in the ntp.conf file: ntpupdate <ntp_server>

* started the ntp daemon: /etc/init.d/ntpd start

* added ntpd to the startup manager: chkconfig add ntpd

* set ntpd to start in default reunlevels: chkconfig ntpd on

Re: How do I resolve clock offset issue?

Explorer

i got the next:

 

$sudo service ntp stop
* Stopping NTP server ntpd [ OK ]
root@cluster-01:~# sudo ntpdate ntp.ubuntu.com
11 Jun 06:47:14 ntpdate[29757]: no server suitable for synchronization found

 

i try to do it with the with NTP .. instead NTPD

 

....

Re: How do I resolve clock offset issue?

Expert Contributor

Hi anton_85

 

Try this article, it explains time zones and settings which is very well explained.

 

http://www.linuxsecrets.com/easyblog/2015/01/30/1374-fixing-date-and-setting-time-and-zone-on-rhel-6...

 

 

Re: How do I resolve clock offset issue?

Explorer

Hi nauseous, 

apprently, the problem is at my firewall, where I can't ping my gateway neither other sites out of my network.

so that's way i can't see it.

Re: How do I resolve clock offset issue?

Rising Star

Hi,

 

If firewall is the problem you can ask network admin to open add chains to that specific URL . or the other way you can set up your own NTP server within that network itself.

 

Thanks,

Sathish

Thanks,
Sathish (Satz)

Re: How do I resolve clock offset issue?

Super Collaborator
Check with your network administrators, they have NTP services you can
point to most likely within the firewall.