Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hub Web UI doesn't work

Solved Go to solution

Re: Hub Web UI doesn't work

In putty connected to the master instace and performed ping gke-hadoop-ubuntu-default-pool-78514257-626p.c.platform-services.internal ..... its responding. Also performed curl http://gke-hadoop-ubuntu-default-pool-78514257-626p.c.platform-services.internal:10002/ (my hue server is down so tried connecting to hive having 10002 port) got this:



I think in putty its connected but in browser its not resolving the hostname....

Re: Hub Web UI doesn't work

@bgooley "How to resolve the hostname on browser host. Can you please explain the solution in detail."

Re: Hub Web UI doesn't work

Super Guru



I'm talking about DNS.


For instance, if using a DNS server for name resolution:


$ nslookup


Server:        x.x.x.x
Address:    x.x.x.x#53

Non-authoritative answer:


My point in this case is that someone got an error saying that the browser could not resolve the IP.

For example, see:


The browser problem showed an issue with the browser and how it tries to communicate with the server host; it had nothing to do with Hue.


Re: Hub Web UI doesn't work

Super Guru



Actually, that stackoverflow may be off target since it talks about public addresses.  Your browser needs to resolve a hostname into an IP so that your computer can connect to Hue.  If that resolution (or mapping) fails then the client (browser in this case) cannot connect to the host specified in the browser's URL.

Re: Hub Web UI doesn't work

I got these WARN in kt renewer under hue log and after two hours of troubleshooting learnt that the PID on Cloudera Monitoring serverices had some conflicts.

Had to stop Cloudera Monitor services

restart cloudera-scm-server and agent

It did all the magic.

Issue resolved..



It might be different for others, though.