Support Questions
Find answers, ask questions, and share your expertise

Installed Ranger in a cluster and running into the following issues -

Solved Go to solution
Highlighted

Installed Ranger in a cluster and running into the following issues -

 
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Installed Ranger in a cluster and running into the following issues -

Explorer

The problem found at this location was that they did not have correct "ranger admin" password in the RANGER CONFIG tab in Ambari. So, when the HDFS was restarted, it tries to create a new ranger repository and it fails due to Incorrect "ranger admin" password. Once the "ranger admin" password is updated correctly, the HDFS namenode started with Ranger authorizer and was able to audit all activities via Ranger Console.

View solution in original post

5 REPLIES 5
Highlighted

Re: Installed Ranger in a cluster and running into the following issues -

2015-09-28 16:28:28,937 FATAL conf.Configuration (Configuration.java:loadResource(2638)) - error parsing conf file:/etc/hadoop/2.3.0.0-2557/0/xasecure-audit.xml

java.io.FileNotFoundException: /etc/hadoop/2.3.0.0-2557/0/xasecure-audit.xml (No such file or directory)

at java.io.FileInputStream.open(Native Method)

at java.io.FileInputStream.<init>(FileInputStream.java:146)

at java.io.FileInputStream.<init>(FileInputStream.java:101)

Highlighted

Re: Installed Ranger in a cluster and running into the following issues -

Is this an upgraded cluster? From which version? Was Ranger installed before the upgrade?

xasecure-audit.xml indicates an older version of Ranger. I just check a new install of Ranger on HDP 2.3 and those files are ranger-hdfs-*.xml.

Maybe there's an old configuration file in the /etc/hadoop/conf directory. Can you list all the files in the conf directory?

Highlighted

Re: Installed Ranger in a cluster and running into the following issues -

New Contributor

Need a bit more information.

As David said, the xasecure-audit entails older versions of Ranger.

  • was this installed through Ambari?
  • if this was an upgrade did you have a previous version of ranger
Highlighted

Re: Installed Ranger in a cluster and running into the following issues -

1] How did you enable ranger plugin for HDFS? Can you share the full error message from namenode log?

2] Make sure all symlinks are pointed correctly and verify current versions set via hdp-select.

Also please provide information requested above by David and Adis.

Re: Installed Ranger in a cluster and running into the following issues -

Explorer

The problem found at this location was that they did not have correct "ranger admin" password in the RANGER CONFIG tab in Ambari. So, when the HDFS was restarted, it tries to create a new ranger repository and it fails due to Incorrect "ranger admin" password. Once the "ranger admin" password is updated correctly, the HDFS namenode started with Ranger authorizer and was able to audit all activities via Ranger Console.

View solution in original post

Don't have an account?