Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Issue during Cluster Installation


Hi Guys,
I have been trying to create a cluster which consists of 4 nodes.
1. Node1 (Master)

2. Node2 (Slaves)

3. Node3 (Slaves)

4. Node4 (Slaves)
I had made the Node1,Node2 and Node3 password less. but facing issue during Node4. I am unable to connect with this without giving passwords.
I used below command to copy the key into node4
"Scp .ssh/authorized_key node4/root/.ssh"

I have tried chmod 600 and 400 but same result.
After this when i tried to install cluster (through Ambari Server) , I face issue during Confirming Hosts.
is give me an error
"/var/lib/ambari-agent/" no such file directory exists
please guide me.
Mudassar Hussain


Master Mentor

@Mudassar Hussain

Can you please try this:

1. Instead of copying the "authorized_key" file using SCP try the following command from ambari server host. Please make sure that you are using the correct FQDN of node4 in the following command.

From Ambari Server Host

# ssh-copy-id  -i ~/.ssh/  root@node4


2. Now on the host (node4) check if the FQDN is set correctly?

On Node4 (check if it has ambari.repo file and it's contents are fine)

# hostname -f
# cat /etc/hosts
# cat /etc/yum.repos.d/ambari.repo
# yum install ambari-agent -y


Now try from ambari UI again.

If it still does not work then try the following approach

Then check if the following command shows the correct ambari Hostname in the "ambari-agent.ini" file?


# grep -A 1 '\[server\]'  /etc/ambari-agent/conf/ambari-agent.ini


If not then edit it then try again from ambari.

View solution in original post



@Jay Kumar SenSharma Thanks a lot.
I got your point regarding HCC Thread. I have Accept the first Answer.
now checking the JDK (JAVA_HOME) issue.


@Jay Kumar SenSharma I already use Be-Default JDK. Please see the screen. Thanks



Master Mentor

@Mudassar Hussain

The Default JDK is usually downloaded and extracted by ambari during the "ambari-server setup" in the following location:


[root@hdfcluster1 ~]# ambari-server setup
Using python  /usr/bin/python
Setup ambari-server
Checking SELinux...
SELinux status is 'enabled'
SELinux mode is 'permissive'
WARNING: SELinux is set to 'permissive' mode and temporarily disabled.
OK to continue [y/n] (y)? 
Customize user account for ambari-server daemon [y/n] (n)? 
Adjusting ambari-server permissions and ownership...
Checking firewall status...
Checking JDK...
Do you want to change Oracle JDK [y/n] (n)? y
[1] Oracle JDK 1.8 + Java Cryptography Extension (JCE) Policy Files 8
[2] Oracle JDK 1.7 + Java Cryptography Extension (JCE) Policy Files 7
[3] Custom JDK
Enter choice (1): 1
JDK already exists, using /var/lib/ambari-server/resources/jdk-8u112-linux-x64.tar.gz
Installing JDK to /usr/jdk64/


@Jay Kumar SenSharma
I have selected option 3 (custom) . this path works for "Node1" and "Node2" .
but in case of "Node3",it gives an error during the "Confirm Hosts" Step